Problems with installing Pfsense SOLVED

I am having a problem upgrading my pfsense box.
This is my current setup.
Version 2.1.5 Free BSD 8.3 release p16
AMD Athlon 64 X2 Dual Core 3800+

Trying to install to a new hard drive so as to not mess will my working pfsense
The version I am trying to install is Version 2.3.4

Using a Sandisk 4gb usb drive to install
Tried using i386 and amd64

After it detects my keyboard, there is just a string of errors and time outs
ex Slot 5 gets a time out and error 5 then slot 6 and so on.
I can get to the install screen, but there is not hard drive listed to install to and there is another long error message as well, then the screen goes from the vga install to the command line and more slot error messages.

1 Like

Have you tried to download and resetup usb?

I downloaded the lasted version from there web site, and used Etcher to install the image onto the usb

ok so you have wiped usb and redownloaded image?

New download and setup on the usb.
My old version of pfsense works, but I can not install the new version onto a new hard drive.
I do not want to lose my working version of 2.1.5

I want the new version 2.3.4 on a new hard drive. The install gets to a point after the keyboard recognition and just give errors on Slot 5 then Slot 6 and so on till it reboots

Use Rufus
maybe it will help

The USB drive boots and pfsense starts to install and then I get errors.

Thanks for the help. Will give it a try.

also maybe run some health checks on hard drive possibly something wrong with it or the old unplug and replug drive in and make sure you have a good connection

Hard drive went through a full health check.
Hard drive shows up in the Bios and at the first part of the pfsense install.
Farther down the install, when I get to the install screen there is no hard drive
The errors say something about ATA in them.

can you post a screenshot or pic of them

Do not know how to get a screen shot in FreeBsd
Do not know if the usb has log of the error, that would be nice, but I do not know where to look, on the usb.

have you tried a cd/dvd? or just some other media than the same USB? Also, have you attempted to boot from USB without any harddrive attached? Have you tried with a different keyboard?

So, these are just a few of the things I would try, right now it is unclear where the problem lies - though if you're seeing it at the keyboard, I would move the keyboard to a different usb slot or just try a different keyboard. The big question is, can we narrow down the cause.

Used a different keyboard moved it to a different usb.
Have not tried a cd/dvd, did not use this because to install the version i have working now, I had to use a USB drive, cd/dvd did not work.
Will give the cd/dvd a try tomorrow.

Here is what I am getting.

Hard drive shows up in Bios.
Put in usb drive an let it boot to get to the vga install screen.
The last good install message is logitech keyboard installed or the apple keyboard both work.
before it gets to the vga screen there is ATA / Slot 5 slot6 i have seen all the way to slot 24 .
Sometime it will get to the vga install screen, and on screen to where it asks to install to hard drive, it leaves the vga and goes back to command line and gives me more errors of ATA and slot number what ever.

I have a working and installed version of pfsense 2.1.5 on this machine what did they do to the install as of this version that I can not install it on this machine to the new version 2.3.4
If I could install and having working for three or so years 2.1.5, why can i not get 2.3.4 to install.

Could you clone your working image on to the new disk and then do an upgrade from within pfsense?

That is an option I have been thinking about.
Will have to find some cloning software.
An suggestions for open software for cloning.

Clonezilla is pretty good

Thanks will give it a try.

I have not had an issue with 2.3.3 or 2.3.4 of pfsense, I did run into this problem when trying to install opensense.

the work around for me was to install pfsense instead of opensense. pfsense would install from a usb stick opensense would not. then when i was messing around i installed an older version of opensense and it was fine. Then i figured out using a usb3 port with a usb3 stick vs using usb2 port with a usb3 stick vs usb2 port with a usb2 stick seemed to be part of the problem. if i tried to install from a usb3 on a usb3 port it failed, if i used a usb2 port with a usb2 stick it seemed to be fine, if i remember correctly i could also use a usb3 stick in a usb2 port but that one i am less sure about.

Then it got even weirder, if I tried to install using uefi sometimes it would work and sometimes it would fail, if i used the fat32 mbr, there did not seem to be a problem or so I thought. then i tried using a dd image vs an iso image, and there was no consistency, sometimes it would install and sometimes it would not.

The conclusion i came to was actually to do what every one says is bad, i virtualized my pfsense using ubuntu server 16.04 as the host with qemu/kvm. then of course you are installing from an iso on the host disk. i have personally had 0 issues with my pfsense running virtualized.

Problem solved.

The Athlon pc 3800+ was the problem. Do not know what is wrong with it, but it does not work for pfsense. There is something broken on it, it has been acting off since the day I purchased it used.
Installed pfsense on a Lenovo office pc Core 2 Duo and it installed in less then 15 min. Had to cut down the network card to fit the half high Lenovo.

Will see if i can do something else with the HP Athlon machine, maybe a experiment linux box. The pc has something wrong with it so can not mess it up any more.

Thanks everyone for helping out.

On a side question.

Does anyone have a good link to get a 2 to 4 port intel 1000 baseT nic Half height card.
There is a lot on ebay, but, who to purchase from that has a good rep.