Problems installing the latest AMD drivers on Ubuntu laptop

I tried installing the Linux drivers in Ubuntu and it keeps freezing anytime i open it. is there another way to install it?

What do you mean freezing every time you open it? Do you mean the sh file, a .deb file or from the software center?

.deb file

Make sure you have all the dependencies installed first.

sudo apt-get install dkms lib32gcc1 libc6-i386 gksu

If you are missing any other dependencies, it should tell you. Instead of installing it from the software center, install it by using this command:

sudo dpkg -i /path/to/file.deb

after you get the drivers installed, make sure to run

aticonfig --initial

update. I installed ubuntu 15 and found out I have to use a ".run" file for this setup. As before it will not run just my clicking it. how to I set this up threw terminal?

this is the file name

You can use that as well, you just need to install all the dependencies that I listed above. To use the .run file:

cd Downloads
sudo ./

Sorry for this but i need help. I have the deb . I just did not think about it. how do i find the path to type in terminal ?

Is it like this?
sudo dpkg -i /path/to/fglrx_15.200-0ubuntu1_amd64_ub_14.01.deb

I also got the location of the file ,it is on a usb drive

Here is the location


and the file is not in any folder just in the usb drive

If you need me to take pictures of whats on the screen let me know

just move it to your home folder to make things easy. Then all you have to do is

sudo dpkg -i fglrx*

The * just tells it to install all packages that begin with fglrx in that directory. (I assume you don't have another copy of fglrx in your home directory)

Ok, i tried it and it says dpkg: error processing archive fglrx (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:

Forget it,only the open source drivers work.

Just take a picture of your terminal and upload it.

I followed this video and it helped me install on the laptop. I want to know if there are any mistakes or warning about this process?
install amd drivers on ubuntu