Return to Level1Techs.com

Problem with bios access Windows/Ubuntu dual boot after upgrade to Ubuntu 20.04

Hello Level 1 linux! First time, long time.

I’ve searched around for answers to my issue but have not yet found a solution. I just updated from Ubuntu 18.04 to 20.04, and in the process I seemed to have removed my dual boot screen and access to the bios in the boot up process. I have tried resetting the cmos, and the default boot-repair through the GUI. I cannot boot into windows whatsoever, but those partitions are still there.

When I boot up the screen is blank until the Ubuntu login screen displays. I am relatively new to linux so I’m assuming I accidentally selected an option I didn’t want in the upgrade process. I have a file of my boot info summary from boot repair if that would help. Thanks for any help.

Boot-info! boot-repair-4ppa125 [20200703_0842]

============================== Boot Info Summary ===============================

=> Windows 7/8/2012 is installed in the MBR of /dev/nvme0n1.
=> Windows 7/8/2012 is installed in the MBR of /dev/sda.

nvme0n1p1: _____________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

nvme0n1p2: _____________________________________________________________________

File system:       vfat
Boot sector type:  Windows 8/2012: FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /efi/Boot/bkpbootx64.efi /efi/Boot/bootx64.efi 
                   /efi/Boot/fbx64.efi /efi/Boot/grubx64.efi 
                   /efi/Boot/mmx64.efi /efi/ubuntu/grubx64.efi 
                   /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                   /efi/ubuntu/grub.cfg /efi/Microsoft/Boot/bootmgfw.efi 
                   /efi/Microsoft/Boot/bootmgr.efi 
                   /efi/Microsoft/Boot/memtest.efi

nvme0n1p3: _____________________________________________________________________

File system:       
Boot sector type:  -
Boot sector info: 

nvme0n1p4: _____________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  Windows 10
Boot files:        /Windows/System32/winload.exe

sda1: __________________________________________________________________________

File system:       
Boot sector type:  -
Boot sector info: 

sda2: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda3: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        /efi/BOOT/bkpbootx64.efi /efi/BOOT/bootx64.efi 
                   /efi/BOOT/fbx64.efi /efi/BOOT/grubx64.efi 
                   /efi/BOOT/mmx64.efi /efi/ubuntu/grubx64.efi 
                   /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                   /efi/ubuntu/grub.cfg

sda4: __________________________________________________________________________

File system:       ext4
Boot sector type:  -
Boot sector info: 
Operating System:  Ubuntu 20.04 LTS
Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub

================================ 2 OS detected =================================

OS#1: The OS now in use - Ubuntu 20.04 LTS CurrentSession on sda4
OS#2: Windows 10 on nvme0n1p4

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.4.0-40-generic root=UUID=9c204ec1-06ae-4ae9-877d-391bf0a0f8af ro quiet splash vt.handoff=7

===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0007
Timeout: 1 seconds
BootOrder: 0007,0005,0000,0001,0006
Boot0000* Windows Boot Manager HD(2,GPT,2c09980c-a2ae-4d9b-9a32-025f6a77fb07,0xfa000,0x31800)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…M……
Boot0001* Hard Drive BBS(HD,0x0)…GO…NO…o.W.D.C. .W.D.S.2.0.0.T.2.B.0.B.-.0.0.Y.S.7.0……A……>…Gd-.;.A…MQ…L.8.1.0.4.5.1.0.8.4.0.4.8. . . . . . . . ……BO…NO…q.S.a.m.s.u.n.g. .S.S.D. .9.7.0. .E.V.O. .1.T.B……A…%8……4…Gd-.;.A…MQ…L.S.4.6.7.N.X.0.K.C.0.7.5.4.2.H……BO
Boot0005* ubuntu HD(3,GPT,32695af0-06b4-4c88-8179-a7301931ede1,0x6ece8000,0x100800)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0006* USB BBS(USB,0x0)…GO…NO…[.H.L.-.D.T.-.S.T.B.D.-.R.E. .W.H.1.4.N.S.4.0. .1…0.2……A……Gd-.;.A…MQ…L.0.0.2.9.3.3.0.0.2.6.7.8……BO
Boot0007* ubuntu HD(2,GPT,2c09980c-a2ae-4d9b-9a32-025f6a77fb07,0xfa000,0x31800)/File(\EFI\UBUNTU\SHIMX64.EFI)…BO

f7a57b08bc7c1c85417ae4cea582d1d4 nvme0n1p2/Boot/bkpbootx64.efi
f7a57b08bc7c1c85417ae4cea582d1d4 nvme0n1p2/Boot/bootx64.efi
bed45d1c9554cea09924d3814cb7c446 nvme0n1p2/Boot/fbx64.efi
5c14b2158486ded02655f86386b249e2 nvme0n1p2/Boot/grubx64.efi
4487628005555bfd4a4c0a47211e0700 nvme0n1p2/Boot/mmx64.efi
5c14b2158486ded02655f86386b249e2 nvme0n1p2/ubuntu/grubx64.efi
4487628005555bfd4a4c0a47211e0700 nvme0n1p2/ubuntu/mmx64.efi
f7a57b08bc7c1c85417ae4cea582d1d4 nvme0n1p2/ubuntu/shimx64.efi
cb8e4284804d56f058c0e1cf111eeedd nvme0n1p2/Microsoft/Boot/bootmgfw.efi
3df357ffd0654bb80f2a575485e6e0cc nvme0n1p2/Microsoft/Boot/bootmgr.efi
f7a57b08bc7c1c85417ae4cea582d1d4 sda3/BOOT/bkpbootx64.efi
f7a57b08bc7c1c85417ae4cea582d1d4 sda3/BOOT/bootx64.efi
bed45d1c9554cea09924d3814cb7c446 sda3/BOOT/fbx64.efi
5c14b2158486ded02655f86386b249e2 sda3/BOOT/grubx64.efi
4487628005555bfd4a4c0a47211e0700 sda3/BOOT/mmx64.efi
5c14b2158486ded02655f86386b249e2 sda3/ubuntu/grubx64.efi
4487628005555bfd4a4c0a47211e0700 sda3/ubuntu/mmx64.efi
f7a57b08bc7c1c85417ae4cea582d1d4 sda3/ubuntu/shimx64.efi

============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda : is-GPT, no-BIOSboot, has—ESP, not-usb, not-mmc, has-os, 34 sectors * 512 bytes
nvme0n1 : is-GPT, no-BIOSboot, has—ESP, not-usb, not-mmc, has-os, 2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda4 : is-os, 64, apt-get, signed grub-efi , grub2, grub-install, grubenv-ok, update-grub, farbios
nvme0n1p1 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, not-far
nvme0n1p2 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, not-far
nvme0n1p4 : is-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, farbios
sda2 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, farbios
sda3 : no-os, 32, nopakmgr, no-docgrub, nogrub, nogrubinstall, no-grubenv, noupdategrub, farbios

Partitions info (2/3): _________________________________________________________

sda4 : isnotESP, fstab-has-goodEFI, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot
nvme0n1p1 : isnotESP, part-has-no-fstab, no-nt, no-winload, recovery-or-hidden, no-bmgr, notwinboot
nvme0n1p2 : is—ESP, part-has-no-fstab, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot
nvme0n1p4 : isnotESP, part-has-no-fstab, no-nt, haswinload, no-recov-nor-hid, no-bmgr, notwinboot
sda2 : isnotESP, part-has-no-fstab, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot
sda3 : is—ESP, part-has-no-fstab, no-nt, no-winload, no-recov-nor-hid, no-bmgr, notwinboot

Partitions info (3/3): _________________________________________________________

sda4 : not-sepboot, with-boot, fstab-without-boot, not-sep-usr, with–usr, fstab-without-usr, std-grub.d, sda
nvme0n1p1 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no—usr, part-has-no-fstab, std-grub.d, nvme0n1
nvme0n1p2 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no—usr, part-has-no-fstab, std-grub.d, nvme0n1
nvme0n1p4 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no—usr, part-has-no-fstab, std-grub.d, nvme0n1
sda2 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no—usr, part-has-no-fstab, std-grub.d, sda
sda3 : not-sepboot, no-boot, part-has-no-fstab, not-sep-usr, no—usr, part-has-no-fstab, std-grub.d, sda

fdisk -l (filtered): ___________________________________________________________

Disk nvme0n1: 931.53 GiB, 1000204886016 bytes, 1953525168 sectors
Disk identifier: 9707895F-2949-4F2B-BA7D-DAACA61E4B4C
Start End Sectors Size Type
nvme0n1p1 2048 1023999 1021952 499M Windows recovery environment
nvme0n1p2 1024000 1226751 202752 99M EFI System
nvme0n1p3 1226752 1259519 32768 16M Microsoft reserved
nvme0n1p4 1259520 1953523711 1952264192 930.9G Microsoft basic data
Disk sda: 1.84 TiB, 2000398934016 bytes, 3907029168 sectors
Disk identifier: 5C59F55C-7DCC-472B-9424-FF5D01AFC48E
Start End Sectors Size Type
sda1 34 32767 32734 16M Microsoft reserved
sda2 32768 1859026943 1858994176 886.4G Microsoft basic data
sda3 1859026944 1860077567 1050624 513M EFI System
sda4 1860077568 3907028991 2046951424 976.1G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:2000GB:scsi:512:512:gpt:ATA WDC WDS200T2B0B-:;
1:17.4kB:16.8MB:16.8MB::Microsoft reserved partition:msftres;
2:16.8MB:952GB:952GB:ntfs:Basic data partition:msftdata;
3:952GB:952GB:538MB:fat32:EFI System Partition:boot, esp;
4:952GB:2000GB:1048GB:ext4::;
nvme0n1:1000GB:nvme:512:512:gpt:Samsung SSD 970 EVO 1TB:;
1:1049kB:524MB:523MB:ntfs:Basic data partition:hidden, diag;
2:524MB:628MB:104MB:fat32:EFI system partition:boot, esp;
3:628MB:645MB:16.8MB::Microsoft reserved partition:msftres;
4:645MB:1000GB:1000GB:ntfs:Basic data partition:msftdata;

blkid (filtered): ______________________________________________________________

NAME FSTYPE UUID PARTUUID LABEL PARTLABEL
sda
├─sda1 2b731e21-e5e5-4edf-bf13-a8fbf620738e Microsoft reserved partition
├─sda2 ntfs F4EE7B4CEE7B0660 ad31cc6e-80f9-4fc4-892a-06ea2c08c614 SataWD Basic data partition
├─sda3 vfat 51CC-9286 32695af0-06b4-4c88-8179-a7301931ede1 EFI System Partition
└─sda4 ext4 9c204ec1-06ae-4ae9-877d-391bf0a0f8af 39333e27-9ba8-4d7d-a708-053aaac38058
nvme0n1
├─nvme0n1p1 ntfs CADCFC15DCFBF991 fb3d004a-b0e6-411b-ac58-dc2c7379ef06 Recovery Basic data partition
├─nvme0n1p2 vfat 72FD-6E4C 2c09980c-a2ae-4d9b-9a32-025f6a77fb07 EFI system partition
├─nvme0n1p3 5beee33e-7183-4cb8-9ae9-f9b1c6bcc2c4 Microsoft reserved partition
└─nvme0n1p4 ntfs 9A5CFF915CFF6683 37fc25bc-7e7b-44fa-b1a2-e636fc4cb807 Basic data partition

df (filtered): _________________________________________________________________

               Avail Use% Mounted on

nvme0n1p1 70.7M 86% /mnt/boot-sav/nvme0n1p1
nvme0n1p2 59.6M 37% /mnt/boot-sav/nvme0n1p2
nvme0n1p4 50.6G 95% /mnt/boot-sav/nvme0n1p4
sda2 140.1G 84% /mnt/boot-sav/sda2
sda4 262.5G 68% /

Mount options: __________________________________________________________________

nvme0n1p1 ro,relatime,user_id=0,group_id=0,allow_other,blksize=4096
nvme0n1p2 rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro
nvme0n1p4 ro,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda2 ro,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda4 rw,relatime,errors=remount-ro

=================== nvme0n1p2/efi/ubuntu/grub.cfg (filtered) ===================

search.fs_uuid 9c204ec1-06ae-4ae9-877d-391bf0a0f8af root hd0,gpt4
set prefix=($root)’/boot/grub’
configfile $prefix/grub.cfg

===================== sda3/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 9c204ec1-06ae-4ae9-877d-391bf0a0f8af root hd0,gpt4
set prefix=($root)’/boot/grub’
configfile $prefix/grub.cfg

====================== sda4/boot/grub/grub.cfg (filtered) ======================

Windows Boot Manager (on nvme0n1p2) osprober-efi-72FD-6E4C
Ubuntu 9c204ec1-06ae-4ae9-877d-391bf0a0f8af
Ubuntu, with Linux 5.4.0-40-generic 9c204ec1-06ae-4ae9-877d-391bf0a0f8af
Ubuntu, with Linux 5.3.0-62-generic 9c204ec1-06ae-4ae9-877d-391bf0a0f8af
Windows Boot Manager (on nvme0n1p2) osprober-efi-72FD-6E4C

END /etc/grub.d/30_os-prober

UEFI Firmware Settings uefi-firmware

END /etc/grub.d/30_uefi-firmware

========================== sda4/etc/fstab (filtered) ===========================

/ was on /dev/sda4 during installation

UUID=9c204ec1-06ae-4ae9-877d-391bf0a0f8af / ext4 errors=remount-ro 0 1

/boot/efi was on /dev/nvme0n1p2 during installation

/swapfile none swap sw 0 0
UUID=51CC-9286 /boot/efi vfat defaults 0 1

======================= sda4/etc/default/grub (filtered) =======================

GRUB_DEFAULT=“menuentry ‘Windows Boot Manager (on /dev/nvme0n1p2)’ --class windows --class os ‘osprober-efi-72FD-6E4C’ {”
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
GRUB_CMDLINE_LINUX=""

==================== sda4: Location of files loaded by Grub ====================

       GiB - GB             File                                 Fragment(s)

1813.086116791 = 1946.786394112 boot/grub/grub.cfg 1
1747.511837006 = 1876.376547328 boot/vmlinuz 2
1712.464733124 = 1838.745006080 boot/vmlinuz-5.3.0-62-generic 1
1747.511837006 = 1876.376547328 boot/vmlinuz-5.4.0-40-generic 2
1712.464733124 = 1838.745006080 boot/vmlinuz.old 1
965.035816193 = 1036.199317504 boot/initrd.img 3
889.522956848 = 955.118002176 boot/initrd.img-5.3.0-62-generic 3
965.035816193 = 1036.199317504 boot/initrd.img-5.4.0-40-generic 3
889.522956848 = 955.118002176 boot/initrd.img.old 3

===================== sda4: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 17123 Apr 15 06:31 10_linux
-rwxr-xr-x 1 root root 42128 Apr 15 06:31 10_linux_zfs
-rwxr-xr-x 1 root root 12894 Apr 15 06:31 20_linux_xen
-rwxr-xr-x 1 root root 12059 Apr 15 06:31 30_os-prober
-rwxr-xr-x 1 root root 1424 Apr 15 06:31 30_uefi-firmware
-rwxr-xr-x 1 root root 214 Apr 15 06:31 40_custom
-rwxr-xr-x 1 root root 216 Apr 15 06:31 41_custom

======================== Unknown MBRs/Boot Sectors/etc =========================

/dev/nvme0n1p1: unknown GPT attributes
8000000000000001

/dev/nvme0n1p2: unknown GPT attributes
8000000000000000

/dev/nvme0n1p3: unknown GPT attributes
8000000000000000

Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda4,
using the following options: sda3/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s win-legacy-basic-fix use-standard-efi-file restore-efi-backups

Final advice in case of suggested repair: ______________________________________

Please do not forget to make your UEFI firmware boot on the The OS now in use - Ubuntu 20.04 LTS CurrentSession entry (sda3/efi//shim.efi (**** will be updated in the final message) file) !
If your computer reboots directly into Windows, try to change the boot order in your UEFI firmware.

If your UEFI firmware does not allow to change the boot order, change the default boot entry of the Windows bootloader.
For example you can boot into Windows, then type the following command in an admin command prompt:
bcdedit /set {bootmgr} path \EFI*\shim*.efi (**** will be updated in the final message)

```

I’ve had this issue with fast boot turned on, the boot is so fast you don’t get an option to select anything.

You could try mashing the Del (or what ever key goes into bios) at boot to try get there.

Or another thing to try is mashing escape key when booting to try get the grub menu to come up, then you might be able to select windows.

If you get booted to windows there is an option under the setup and repair setting to do advanced boot. Then on there is an option to boot to the bios from Windows that should work.

It also looks like your ubuntu install is on a secondary drive, so you could just remove that temporarily to boot into windows and disable fast boot in the bios to get the ability to get into bios.

If you really want to continue to use fast boot you can edit your grub file to force it to display an is selection menu for a few seconds at boot.

Just google removing grub silent boot…

Hope this helps

Thanks Cpn, I’ve tried mashing the buttons as much as possible but I haven’t had any success yet. I’ll try removing the silent boot since that second drive is a m.2 on the back of the motherboard and isn’t easily accessible. SFF ITX cases are awesome, unless you need to work on them… But that is a good suggestion. Thanks.

@Cpn-Neemo Hm… Fast Boot is a Windows feature, so that has no barring on the issue at hand.

@fellowzombie You can just edit /etc/default/grub to get a proper timeout. An example from my file:

***
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=90
***

Once you edit it with the timeout of your choosing, just run sudo update-grub and you’ll be good to go.

Also, you can enter the UEFI through the GRUB menu. Just look for an entry that has “firmware” in it.

1 Like

Thanks @Cpn-Neemo and @elsandosgrande.
So what was confusing me is I had what @elsandosgrande described in my grub menu:

***
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=15
***

But problem ended up being that GRUB_DEFAULT was pointed at the wrong location. I solved it through :

GRUB_DEFAULT = 0

Thanks for everyone’s help. I don’t know how I screwed up the default grub. But it works now and boots with a firmware splash screen and the boot loader!

Hm… I’m not sure how the default entry could have changed…

I don’t know either. I know it was messed up before I downloaded the boot-repair tool. But it could have been my fault somehow during the upgrade process.

What’s even more confusing to me is that changing the default entry should just change which entry is highlighted when the menu first appears.

Anyways, given that you found your solution, mark it as such (mark your post in which you describe your solution).

Have a nice day/Good night!

Yes this is true, but some motherboards like my Gigabyte AORUS gaming 5 wifi have a feature called fast boot in Bios that skips over checking things and dosent post any info to the screen when I have mine set to full fast boot. It boots so fast the wireless keyboard dosent initlise until after the splash screen. Requiring me to find another keyboard or using the Windows boot to uefi.

I fixed my issues by using rEFInd as my boot loader much nicer than grub for pure efi booting but that’s just my opinion. Anyway that’s enough off topic.

Damn… I didn’t know that some motherboards actually have Fast Boot integration.

I wonder how things would behave with systemd-boot

If anyone else has this problem there are a couple of helpful things to try. If the drives are booting so fast that you can’t get into UEFI/BIOS then unplug them. Hard for them to boot that way. I’ve also had that problem with Ubuntu and derivatives where they modify grub and hide the splash screen. You can get it to appear by holding shift after POST.

1 Like

Ah shift that’s the one, I thought it was escape. Thank you for this I’ll put it in the memory banks for next time.