[Problem] Raspberry Pi 2 with external HDD

I have a raspberry pi 2 with owncloud installed on it. Now I want to connect a WD Elements 500GB for storage.

I get the same result with every USB port. The HDD is a USB 3 device but it is compatible with USB 2. I also connected it to my Pi B and it didn't make this noise.

output of lsusb:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub 
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.  
Bus 001 Device 005: ID 1058:1078 Western Digital Technologies, Inc.

That is not enough power!

Try powering the Pi through a higher amperage source, however you may require an external drive which can take external power itself.

In summary. The Pi itself requires 5v with a minimum of 500mA to run. (typical USB output) The external drive most likely needs (quite likely) more than that to spin it up. So, you need to increase the power available to the Pi so it can pass that power through (though the Pi's PSU may not be able to handle it)

The Pi has a PSU with an output of 2A.
The HDD is USB 2 compatible so it should require a maximum of 500 mA (no extra cable required for 2.0 compatibility) and the maximum current all USB peripherals can draw from the USB port is 600mA.
I tested both Pis with the same PSU.

USB 2.0 along with 3.0 is rated to run at anywhere between 150mA to 900mA. Bear in mind that the power being delivered to the USB portion of the Pi also is designed to power the plexing chip that gives you multiple ports. (as the ARM SoC they use only has one USB built into it)

Also, your OS is reporting the USB device. However the click is indicator of power issues. If it were an OS issue it would not report the USB device.

So quick question, it worked perfectly fine with the older Pi?

I SSHed into the Pi B and can access the HDD without any problems.

Do you have a Y splitter USB cable that you could use to inject additional power or a powered USB hub you could connect to?

Interesting quote here from the Rasp Pi FAQ:

The maximum power the Raspberry Pi Model A and B can use is 1 Amp, so if you need to connect a USB device that will take the power requirements of the Raspberry Pi above 1 Amp then you must connect it to an externally powered USB hub. Alternatively, the maximum power the Model B+ can use is 2 Amps before needing to connect devices to an externally powered USB hub.

Has the PSU of the Pi 2 dropped back to the spec of the older Model A and B. With which that could causing the problems.


What do you exactly mean? I just use a normal USB Type B cable. The same I use for charging my Oneplus One.
I try to get exact power usage numbers tomorrow.

What I am referring to is the actual voltage regulators on the Pi itself. The amperage they could pass through was increased from the Model A to the B+. What I was getting at is: Were the voltage regulators dropped back to that of the Model A instead of the B. Hence making it incapable of higher amperage draw devices like portable HDD's.

I am not questioning your power supplies but the voltage regulators on the Pi itself and why one model can handle the drive fine and the other can not.

Unfortunately the power draw for the newer Pi 2 is not listed anywhere, hence I can not make the comparison.