Problem launching Steam (Linux) after running with Lutris

Upgraded to new PC. Running Ubuntu 18.04. Latest kernel. I wanted to test some games, wine, etc., so I installed Lutris (first time using it).

However, after not really liking it, uninstalling, etc., I found that I could no longer launch Linux Steam. It gave the below message. I messed around with it for a few hours, doing a complete uninstall (of Steam), getting rid of all related folders, files, etc., and nothing worked.

After some time, I decided to check Lutris again, so I reinstalled it. After installing it I, again, reinstalled Steam, and after syncing, right clicking and hitting run on Linux Steam (from within Lutris), it would launch no issue. However, I still cannot launch just Steam from terminal or apps without it failing and giving below message from terminal.

Is anyone familiar with this issue and how to resolve it? I guess I could use Lutris until I resolve it, but I would like to go back to using regular Steam and POL/Wine.

I will eventually try re-installing Ubuntu, to see if that works, but it is difficult with the 2200g, because it doesn’t work with current boot-usb. I have to use dedicated graphics (which I don’t have readily available) for install until I can update kernel, etc.

Running Steam on ubuntu 18.04 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2018-08-26 14:06:28] Startup - updater built Aug 8 2018 21:32:23
Looks like steam didn’t shutdown cleanly, scheduling immediate update check
[2018-08-26 14:06:28] Checking for update on startup
[2018-08-26 14:06:28] Checking for available updates…
[2018-08-26 14:06:28] Download skipped: /client/steam_client_ubuntu12 version 1533766730, installed version 1533766730
[2018-08-26 14:06:28] Nothing to do
[2018-08-26 14:06:28] Verifying installation…
[2018-08-26 14:06:28] Performing checksum verification of executable files
[2018-08-26 14:06:28] Verification complete

I would start with deleting the ~/.config/lutris folder that will still be in your home. If that doesn’t work, do the same with ~/.steam and then reinstall steam.

I’m pretty sure those were gone when I reinstalled steam.

I ran:

rm -rf ~/.local/share/Steam && rm -rf ~/.steam

For Lutris I just searched all folders/files from home and deleted the config, local and some other files that remained after uninstall.

It is working now. I don’t know what the issue was.

1 Like

Welcome to Linux