PowerPC Linux for G4 Mac via USB stick?

I have a G4 powermac I salvaged. It didn’t hav a hard drive. So I salvaged (from elsewhere) a 200GB Maxtor HDD. Now I just need to figure out how to get an OS onto the system. I wanted to use a PowerPC release of Linux but I have no optical disk drives in the house that I can use to burn a disk with. I need to be able to put it on a USB stick. So can I do this (with a windows machine)?

1 Like

Pinging @FaunCB

Well you need to look up the open firmware commands to boot from a usb. If you found it with the drives stripped I’d run the auple hardware test on it first and make sure it all does a full detect.

Furthermore, I wouldn’t run linux on a G4, even a 1.67ghz one that you have on phase change and processor overclocked like crazy. As long as its a 1.2 ghz chip or faster, you could run osx 10.5 comfortably with brew and macports, install roccat as your browser(the only modern ppc browser left) , and you’ve got a solid machine. If not osx, run openbsd.

And get rid of that maxtor those explode.

1 Like

the Maxtor is a temporary solution. It was what I had on hand. How do I get the DMG image onto the stick that will be recognized by the powerpc architecture. I guess that’s where I’m more lost than anything else

First question is do you have a mac? If no, find one. Or burn a disc.

Go on youtube and look up Its My Natural Color. He’ll teach you whatever the hell you want to know. Anywhing else I’ll tell ya tomorrow. I’m wooped.

1 Like

So I guess I’m going to abandon the idea of Linux. And try and get a hold of a copy of OS 10.4.

Pm me

You could run Debian’s PPC build.
Still need to use the open firmware commands though.

I had Debian GNU/Linx PPC build on my G3 IMAC before giving it away to a friend. Worked fine. Was faster than OS X and more feature-ful than OS 9.4.4

Did this with a G4 PowerMac . Burned a USB with the PPC version of Debian, got into OpenFirmware on the Mac by holding down super+alt+o+f (Super=Windows/Command key) and pressing the power button at the same time and booted with these commands:
dev usb1
boot usb1/disk@1:2,\\yaboot
If usb1 doesn’t work, use usb0 instead. Was pretty slow though since it was USB 1.1

1 Like

how long would you say you waited? Every time I get things up to a boot screen it seems like it’s frozen. I usually give up on waiting.

Did you get to typing in the ‘install32’ part?
Are you sure you you got the 32bit PPC iso from here?: https://cdimage.debian.org/cdimage/archive/8.10.0/powerpc/iso-dvd/
If so, give it a few minutes, USB 1 only transfers at about 1MB/s A DVD would be WAY faster.

So I went through the Debian install and it seemed fine. When it went to boot here’s what I got. With BSD it went through and then started looping the boot. Not sure what to do or where to go from here. tempted to give up at this point.

Well thats weird. Its trying to boot the VMWare image for some reason? Uhhh

right i’m incredibly confused here. the installation went smooth as silk otherwise. not sure what this is all about


What EXACT machine do you have? MA/ number and A#### number. I’ll give you a hand with this in an hour.

M5183 I think…I have a copy of OSX Tiger I’m going to try to install just to see what happens. I prefer Linux so once I establish an OS will work on this thing I’ll move back into setting linux up. I really appreciate all the help so far.

VMware image? If your reference to the /boot/vmlinux bit, that’s just the normal Linux kernel image.

@weekendgameguy that error looks like it can’t read the kernel from the hard drive. If the BSD install is boot-looping, there may be a problem with the hard drive?

That’s probably the best thing to do.

OSX Tiger worked just fine… Weird. Well, it’s working and I can goof around with it; so I’ll be content for now. Thanks for the help everyone.

Your error transcribed for easier reading:

Welcome to yaboot version 1.3.16
Enter "help" to get some basic usage information
boot: Linux
Please wait, loading kernel...
/pci@f2000000/pci-bridge@d/mac-io@7/ata-4@1f000/@0:3,/boot/vmlinux: Input/output error

I found people with similar errors on forums.debian.net, linuxquestions.org, and forums.gentoo.org.

Still trying to read through and work out what it could be.

@FaunCB : vmlinux is the uncompressed kernel image

1 Like

Sorry about yesterday I was absolutely exhausted… It’s annoying that I keep wanting to just sleep.

Anyways, depending on your G4 tower the OFW might need to be updated. This can be done through OSX with tools on the apple website. I still recommend FBSD if you aren’t going to run OSX though.

Furthermore, there are many websites with software. MAC POWERPC, The PowerPC Archive, and TenFourFox / Roccat are going to be your best starts. Have fun!

Edit: Also I invite you to the Power and POWERPC news thread that me and @torpcoms have going on. Pretty fun.