PowerEDGE and PCIe

Hi All,

Wondering if anyone can shed some light on why a GTX1070 won’t achieve PCIe 3.0 in a Dell PowerEDGE T620.

The motherboard is PCIe 3.0 compatible same with the CPUs installed.
It’s not a huge issue especially seeing how all the 1070 does is provide hardware acceleration for Plex, it has me baffled non the less.


No one has come across this or has any input at all? I find that rather odd.

Maybe this is the usual shunning of new users to forums - point me towards your right of passage.

Is there any BIOS options that allow you to change the PCIe generation on the slots?

Hey 2bitmarksman, thanks for dropping a reply :slight_smile:

Unfortunately no, the only BIOS settings that would effect PCIe performance would be global power/performance settings and possibly the power budget which are set to high performance with no power budget respectively.

Here is a pic of the BIOS submenus available for configuration.
If anything sticks out to you let me know and i’ll take a deep dive.

Have you checked it under load to see it is changes?

It seems to be an issue with x79 motherboards.
Think I’ve fixed it with some googling - just doing some testing now and will report back.

Okay, so i followed some instructions on another forum about adding a reg key to the GFX card config which forces it into PCIe 3.0 speeds on x79 platforms.
This worked so I then removed the key (which after a reboot reverted the card back to PCIe 2.0) and used nVidias force-enable-gen3 tool instead, this essentially does the same thing and adds the reg key back in.


Interesting problem and fix. Neat!

1 Like

Thank you for posting the solution! These are the type of little quirks that make enterprise equipment and gpus a bit of a tricky situation.

1 Like

Any chance you could link the solution, or paraphrase for anyone in the future?

I guess it would be something like DWORDname=x, value=xx, and the location=System/machine/user/folder/folder1/whereverthewordgoes…

1 Like

I’ll trade a 9800 gt katana for that 1070 :U

1 Like


here you go

1 Like

Thanks man

This topic was automatically closed after 2 days. New replies are no longer allowed.