PoP OS Installation black screen

Hi Everyone,

Was trying to install Pop!_OS but… unsuccessfully. When it should boot from USB drive it only displays black screen. If I hit enter it just starts booting windows. What am I missing? What magic spell I have to whisper to boot into insallation properly as I woudl like to have dual boot?

PS Specs:
AMD 6800XT
AMD 5800X
32G RAM
Tomahawk x570
Dual 4k Displays

P.S. Same thing happens with Ubuntu installation.

Use only one display. Multi-monitor 4K plays havok on Linux live CD installers.

2 Likes

Will try and get back to you afterwards.

Nope, still same results. Just black screen on single monitor.

Use Ventoy to create your installation media instead.

  • did you try disabling secureboot? afaik they fixed that issue with the recent LTS but before then secureboot was causing problems.

  • what did you use to flash? Balena? disks util on other distro? rufus?

  • have you tried using a different drive or usb port? ima guess you prolly have but, ya never know!

  • have you tried the fix others have suggested in pop support of (your mobo specific) turning on CSM in OS boot and enable legacy + UEFI in boot menu?

Good luck :slight_smile: and plz feel free to report back!

1 Like

I would suspect secureboot first, then faulty live media or wrong boot option, probably need to make sure efi is specified. On my X570 board a fairly recent bios update turned on secure boot on by default and l had to manually disable it before l could even boot back into my os… The efi issue I have had with multiple live iso’s as well on this specific board, my old B450 board would automatically use the correct type but now there are always like three options and somehow it manages to select the wrong one every time.

1 Like

Thank you everyone for your answers! It did motivate me to keep on trying.
Ah, if it would not be me that when I was certain that secure boot is disabled and completely forgot that recently flashed BIOS update lol.

That was resolved. Disabled Secure boot, it still did not want to boot.

Eventually discovered that first time I was failed by good ol’ Rufus. Balena Etcher made it boot!

However, now facing another “hiccup” on installation. I am looking to install into secondary NVME/SSD. Creating partitions 1024MB (FAT32, For boot/EFI), And rest for root (EXT4). When selecting these partitions setup is failing with the logs ending with:

WARN: kernelstub.Config : INFO Looking for configuration…
WARN: EFI variables are not supported on this system.
WARN: kernelstub.NVRAM : ERROR Failed to retrieve NVRAM data. Are you running in a chroot?
WARN: Traceback (most recent call last):
WARN: File “/usr/lib/python3/dist-packages/kernelstub/nvram.py”, line 55, in get_nvram
WARN: return subprocess.check_output(command).decode(‘UTF-8’).split(’\n’)
WARN: File “/usr/lib/python3.10/subprocess.py”, line 420, in check_output
WARN: return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
WARN: File “/usr/lib/python3.10/subprocess.py”, line 524, in run
WARN: raise CalledProcessError(retcode, process.args,
WARN: subprocess.CalledProcessError: Command ‘[’/usr/bin/sudo’, ‘efibootmgr’]’ returned non-zero exit status 2.
WARN: kernelstub : INFO System information:
WARN:
WARN: OS:…Pop!_OS 22.04
WARN: Root partition:…/dev/sda2
WARN: Root FS UUID:…[redacted]
WARN: ESP Path:…/boot/efi
WARN: ESP Partition:…/dev/sda1
WARN: ESP Partition #:…1
WARN: NVRAM entry #:…-1
WARN: Boot Variable #:…0000
WARN: Kernel Boot Options:.quiet loglevel=0 systemd.show_status=false splash
WARN: Kernel Image Path:…/boot/vmlinuz-5.19.0-76051900-generic
WARN: Initrd Image Path:…/boot/initrd.img-5.19.0-76051900-generic
WARN: Force-overwrite:…False
WARN:
WARN: kernelstub.Installer : INFO Copying Kernel into ESP
WARN: kernelstub.Installer : INFO Copying initrd.img into ESP
WARN: kernelstub.Installer : INFO Setting up loader.conf configuration
WARN: kernelstub.Installer : INFO Making entry file for Pop!_OS
WARN: kernelstub.Installer : INFO Backing up old kernel
WARN: kernelstub.Installer : INFO No old kernel found, skipping
INFO: running “chroot” “/tmp/distinst.gmWVFiI2dns3” “efibootmgr” “–create” “–disk” “/dev/sda” “–part” “1” “–write-signature” “–label” “Pop!_OS 22.04 LTS” “–loader” “\EFI\systemd\systemd-bootx64.efi”
ERROR: configuring bootloader error: command failed with exit status: exit status: 2
ERROR: errored while installing system: command failed with exit status: exit status: 2
INFO: Install error: command failed with exit status: exit status: 2

Any suggestions what could be causing it?

Just to confirm, the destination SSD/NVME is in full working order, no issues with reads, writes to it (under Win it is working ok).

1 Like

:partying_face:

Back when we first started using and learning linux at school, we had flashing problems too, but with balena! for some unknown reason, balena was bricking usb sticks! so even though Rufus might have been a bit naughty, remember this can happen with any flashing util! ^^


random thoughts and musings

Summary

Now why do i get the feeling that this also goes back to secure boot as well…or through trying to run multiple efi partitions (which should not be a problem but others have reported this has been for them)…humm you did say in OP that you were dual booting right, like not running on bare metal? This is one of the slightly annoying things about previous versions of Pop and the secure boot and uefi issue that was supposed to be resolved grr

Okay, please please :pray: wait for others to reply to this thread if you can before doing this (or anything i suggest, cuz i am still on my linux training wheels lol) but from what i am seeing from the Pop articles and Pop chat, you might be best (if you have to dual-boot and don’t just want to run Windows in a VM, or do all the vfio stuffs) if you’re able to, do a full backup like an image of your windows partition, then start from a blank slate on all your drives doing a pop install, configuring your partitions as you want then installing windows with your backup image into an allotted partition (or completely separate hdd if possible) then doing all the necessary sorting for boot

Pop can be twitchy, and not all distro’s seem to have this issue, and also lol, not every popOS user has this issue either!! plenty of people dual boot without any issue…like in reality there should be no issue with this stuff…We shouldn’t need to go legacy or switch off secureboot.

Would love to be able to actually help instead of throw a bunch of random thoughts at the wall but i will leave it to better and brighter minds to hopefully come to your rescue :blush:

Anyone else please feel free to add to this or put up big blinking warning lights with a “noooooo!” if required…


Sorry, wish i could help but someone with more technical experience, esp with dual boot issues will have to help, but good luck :pray:

1 Like

Thanks for reply!

Ha, after double checking that

it was… sorry to disappoint. It was not secure boot. However, somehow I made it work! Funny enough, installer was still saying that it has failed!!
:smiley:
So, the steps I took that it has resolved the issue was to convert dedicated disk to GPT. than tried to install, installed was complaining, thought screw it, will give it a go later next time and restarted PC and to my surprise it booted to POP_OS! :smiley:

Than followed YouTube video that at the end is managing boot menu and wooohooo! It works now :slight_smile:

Youtube video that I have followed for boot menu:

Now lets see how much patience yet another attempt to use linux (ANTI- macOS as I call it) will last.

P.S. THANK YOU EVERYONE! These things (supporting each other) makes Linux community great!

1 Like