Return to Level1Techs.com

Phone doesn't connect over USB 3.0 ports

helpdesk
#1

When I plug my phone (V20 vs995) into my desktop, I can only transfer data using a USB 2.0 port. It charges faster when connected to a 3.0 port but is not detected (nothing in lsusb or dmesg in Linux, nothing in device manager in Windows). But the 3.0 ports on my laptop work fine, charging the phone and detecting it as expected.

This affects all 3.0 ports on my desktop, front and rear panel. USB 3.0 flash drives work correctly and run at 3.0 speeds so the ports aren’t dead or damaged.

I thought it was the cable at first—not all of the pins are populated on the type-C end, and the type-A end only had the pins for USB 2.0. But I got a shiny new 3.1 gen 2 cable and same symptoms. (Again, behavior is perfect on my laptop with this new cable.)

I’m pretty sure it’s my ancient broke-ass motherboard (GA-970A-UD3P). I’ve already tried playing with the legacy USB/xhci hand-off settings in my UEFI, but no dice. If there are any more troubleshooting steps to take, though, I’d love to know. Syncing my music library at 480 MB/s suuucks.

0 Likes

#2

Have you tried using the newest USB drivers on the motherboard site, or looking for even newer ones directly from Via? It seems USB3 is through a VIA® VL805.
Also have you tried plugging it into another computer to check it isn’t the phone being dumb?

0 Likes

#3

Yeah the phone plays nice with my laptop. Just the desktop that’s giving me trouble.

I found some drivers on Gigabyte’s website, but no dice. Via’s website is pretty iffy but I think it had an updated version. Wouldn’t install, though, and now I can’t uninstall the original drivers through their installer…forgot how much I hate dealing with drivers. I think the takeaway here is that drivers explicitly written for Win7 mean it’s time for a new motherboard. Imma quit before I brick my install or something, but thanks.

0 Likes

#4

You can try and find the .inf file and right click, install that way. Might be worth trying. At worst, USB3 will stop working until you can remove all its drivers and install the default ones again.

1 Like

#5

I extracted the files from the installer and found the inf files (located in the WIN7 folder), but no change. It’s nice that it doesn’t mess up my existing drivers at least.

I use linux most of the time anyway so getting it to work on Windows only isn’t really my goal. Thanks for the tips though.

0 Likes

#6

Too easy. USB3 was in it’s awkward phase about the time your board was made it seems!

0 Likes