PFSense with Linksys 1900ACS

Hey all,

I've been trying to get a Linksys 1900ACS working behind a PFSense router. Tried several different settings according to Linksys and PFSense documentation, but was unable to get it working. Plus I have successfully added the 1900ACS behind a cheap Actiontec router before, so not sure what I can do.

Anyone have any ideas?


What IP addresses are you assigning each device? Are you doing the linksys as a full router and firewall or just in access point mode?

1 Like

The IP address off the pfsense router for that nic is I have that interface running with a DHCP server with a subnetmask of /24.

On the linksys, I've tried putting it into leaving it with DHCP as the connect and turning off the DHCP server; tried bridge mode; tried static ip connection with correct subnetmask; and I've tied various combinations.

I was using this pfsense documentation and this Linksys documentation as reference, which failed.

Should be able to setup pfsense and i believe default ip for it is and then turn off dhcp and set the router to or .5 and you should be good to go.

Sounds fine. How is your linksys connected to the network? My ASUS wouldn't get lan access in AP mode except when connected via the WAN port.

I was considering that... In case the linksys is just acting weird since it did work behind that other router. I just didn't want to swap my normal pfsense "lan" connection since I'm on that right now haha.

I was trying both the WAN port and I tried the LAN ports. I had it working with the WAN port when it was behind that other router before, so I've been mostly trying that way.

To do what exactly? Just as an access point?

Yes, trying to use it was an AP.

It'll work in router mode but it's going to require further configuration and unless your wanting to make a sudo dmz there's no reason to do it that way. Set the linksys in AP mode in DHCP then plug in the lan connection into the wan port.

1 Like

That should be pretty easy but I don't know the stock firmware. I have a WRT1900AC v1 running openWRT as an access point and that went super easy. Maybe consider that?

There is no clear AP mode in the firmware. There's a Wireless bridge mode, but I can get that working at all. Someone else just suggested going with openWRT; I may try that tonight or tomorrow after work. Thanks for the suggestions though. I'll reply back if I'm still up shit creek haha.

1 Like

That sounds like a pretty solid idea. I'll try that after dinner tonight or after work tomorrow. I'll reply back if I still can't figure it out. Thanks man.

1 Like

Yeah that's probably your best bet. Wireless bridge is going to be.... a bridge connection. Not what you're looking for

I've been grasping at straws the last few hours working on this. It's fried my brain since it didn't make any sense what was happening, thus even trying bridge wifi haha

@sanfordvdev @Yockanookany @noenken

Got it working... combination of finding mistakes in the firewall and switching firmware to OpenWRT. Thanks for all the help guys. Slainte!


Was this by chance to get the wireless and LAN on the same subnet for things like Chromecast?

I have a different router but I can't get my lan and wlan to play nice. So to have my pc be able to chromecast, I have it into my old router which is into the pfsense router...and I hate the setup. I was thinking of running wireless off my pfsense box to fix this.

EDIT: not a super necro, but sorry to bring up an older thread

No sorry. I've got my wifi on a different subnet than my wan. I just made it a different interface for how I set up my stuff. I currently have a 4 port 1Gbs Nic in my pfsense router. Sorry for the late reply as well.