PfSense VLAN cannot access internet

I have a VLAN set up in pfsense and the devices on the VLAN are connecting correctly and can ping the router and other devices on my network but don’t have internet access. I’m fairly certain this has to do with firewall rules and the fact that I have VPN gateway set up. I have tried a couple different firewall rules to see if I could get it working but I have no luck. This is the only rule I have now.

I tried copying the default LAN allow all rule and just changing the source but that didn’t work so I changed to this. I have a feeling it has to do with my outbound NAT rules somehow but I am unsure what I would need to change and my WAN is set to the default gateway so I’m not sure why it wouldn’t be working.

Do I need to add or change any rules? What can I do to troubleshoot further?

It probably is the outbound NAT rules. What you need to do is copy the ones you have but change the source to your VLAN subnet. Essentially you need one of each type of rule for each network and each gateway.

Also for your firewall rules specifying a gateway will work for Internet traffic however if you want to have traffic across your local networks the gateway will need to be set to the default gateway, so something to keep in mind.


That worked perfectly. I don’t know why I didn’t think to try that myself. Thanks for your help!

1 Like