Return to Level1Techs.com

pfSense OpenVPN Remote Access has LAN Access but not Internet

helpdesk
pfsense
vpn
#1

I set up OpenVPN to have remote access to my home LAN while I am away. It works except I can’t access the Internet. I can only access things on the LAN. I can ping my LAN devices but not any DNS IP addresses such as 9.9.9.9. I think this is an Outbound NAT issue because I have it set to ‘Manual Outbound NAT rule generation’ because months ago I set up PIA with aliases and I have certain devices only going over PIA with a killswitch but that was a while ago and I think I forgot everything I learned >_>. I have tried googling around and trying different rules but I’m not having much luck.

I do have Redirect IPv4 Gateway checked. If I disable it LAN and Internet work but I want all traffic tunneled through the VPN connection and go out of my home WAN.

Here is the guide I used when setting up OpenVPN Remote Access if it helps but it looks pretty straight forward.

0 Likes

#2

Uncheck Redirect IPv4 Gateway

0 Likes

#3

I just edited to clarify this :slight_smile:

0 Likes

#4

So I understand this right you want both a VPN out and into your network?

0 Likes

#5

I’m saying don’t have it checked.

0 Likes

#6

I already have X number of LAN hosts routed out through Private Internet Access on my home network.

Now I want to have my phone/laptop set to route all of its traffic through an always online VPN (with killswitch) to my home LAN to access my LAN devices when I am outside my LAN but also have internet traffic routed through my home WAN port. So that I can a) Access my LAN devices on the go, b) have a VPN up for public Wifi, and c) use my pfblocker when outside my LAN.

If I uncheck Redirect IPv4 Gateway and for example, I am on my phone and this VPN is connected then I can access my LAN devices but all internet traffic is still going through my phones internet connection. If I look up my IP it shows an AT&T IP when I want it to show my homes internet provider.

Hopefully, that makes sense?

0 Likes

#7

OK I didn’t realize you want to route your internet traffic through the VPN too.

0 Likes