PDP Xbox 1

I just installed mint 20 and I can’t figure out how to find drivers for this controller . Thanks

Is this a wireless controller?

Linux has native drivers for xbox controllers, through the xpad driver.


It should “just work”

One minute, I’ll grab my controller and see if I can recreate the issue.

No light and dead in American truck sim

So if you unplug the controller, open up a terminal and run the command dmesg -w, then plug in the controller, you should see some messages come up. Can you post them?

For reference, this is what I get when I plug in my controller:

[ 7173.126305] usb 1-1: new full-speed USB device number 5 using xhci_hcd
[ 7173.307804] usb 1-1: New USB device found, idVendor=1532, idProduct=0a14, bcdDevice= 1.01
[ 7173.307809] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7173.307812] usb 1-1: Product: Razer Wolverine Ultimate
[ 7173.307815] usb 1-1: Manufacturer: Razer
[ 7173.307817] usb 1-1: SerialNumber: REDACTED
[ 7173.918396] input: Generic X-Box pad as /devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/input/input38
[ 7173.918460] usbcore: registered new interface driver xpad

It may have been steam. I opened the game and it crashed im reinstalling it now ill let you know… Thank you!

1 Like

Sounds good. :+1:

Xboxdrv, or, steam.

Got it fixed it was the game steam had a corrupt file worked with another install! Thanks all!!

1 Like