PC Suddenly will no longer boot ANY OS, displays splash screen then hangs and then black screens

Hello guys,

Hopefully someone can help with this. I was in the middle of watching a YouTube video today, when my PC suddenly froze and then black screened. I proceeded to turn my PC off via the power switch at the back, and then boot into Windows 11 again. Only, this time is proceeded to the Windows 11 boot splash (with the animated loading bar), and then after a few seconds it froze, then finally displaying a black screen.

To then make sure it wasn’t an issue exclusive to Windows 11, I attempted to boot into my Manjaro installation on a separate SSD, only to be met with the same behaviour.

I have attempted

  • Re-seating my GPU;
  • Resetting BIOS (both via menu and removing CMOS battery);
  • unplugging all USB devices;
  • Only using 1 display;
  • and using HDMI instead of DP

My System Specs Are:

  • AMD Ryzen 7 2700X (not overclocked)
  • AMD RX5600XT (XFX Thicc 2)
  • ASUS Prime 5450M-A Bios version 3211
  • x2 Corsair 8GB sticks @ 2133Mhz
  • Windows 11 is on a Crucial M500 M.2
  • and Linux (Manjaro) was on a corsair SSD

Also to note: I am able to get into the BIOS, and when a reset the CMOS I get 2 keyboards and 1 mouse detected, even when I only have 1 keyboard plugged into the USB ports and that’s it.

Any help would really be appreciated, I have been trying to search for answers for hours but to no avail.

Okay, so I enabled added the debug boot param to my Manjaro installation, and now I get the error causing my issue (at least on Linux?):

The last message printed is: fb0: switching to amdgpudrmfb from EFI VGA.

I’ve tried searching around as to what this means exactly, but haven’t found anything.

can you boot from a USB drive?

I’ve attempted to boot from USB, but get the same error.

This sounds like a GPU fault, as it crashes trying to load the AMD GPU frame buffer. Do you have on-board video or another GPU to test with?

1 Like

Left-of-field idea but, since you installed Win 11 - when you reset your BIOS, did you re-enable TPM? If not it could be hard-locking because it’s tuned off.

1 Like

I tried to turn it off and then back on again, but it equited to nothing. :frowning:

Unfortunately I don’t have on-board video or another GPU. Would it be worth going into town today and asking if a OC repair shop could test it?

1 Like