PC sometimes failing to POST after upgrade

Yeh, I don’t think that is worth your time, unless you can convince them to replace your motherboard too. They are not going to be very helpful when they find out you installed the drive anyway even after seeing it’s condition.

F******k!!! It was turning on perfectly yesterday 10 times and now I turned it on again and it’s stuck on code 94 again!

So in the hundreds of times that I’ve use memtest86, I’ve never once had it freeze up where there wasn’t an underlying configuration issue (xmp, timings, volts, etc) or a hardware fault. My suggestion is to keep testing and try to establish a baseline with repeated lockups. Then take note if it freezes again at 86%. If not, does it seem to freeze up sooner the 2nd time after the system is already warm? Have you tried a different DIMM in slot A1? Can you see if it will boot with a single DIMM in B1 and test again? And then try clearing CMOS and leaving all your settings at default (including XMP off).

And as a last resort, I’d try reinstalling your old GPU if you still have it. Since memtest86 doesn’t check VRAM I wouldn’t think it would directly cause a GPU fault, but there still is a slim possibility the card could be responsible.

I know this sounds weird to say, but hopefully you can get consistent freezing and narrow down the root cause. It’s possible whatever caused the lockup is also causing your post issues.

That’s the problem, there’s zero consistency, I can’t pin it down :frowning:
In Windows everything works perfectly fine, BIOS posts or not completely randomly. I tried it with so many combinations of memory sticks, GPU in different PCI sockets, SSDs in different M.2 sockets… Last night it seemed like everything is fine, I tried shutting it down and starting up around 10 times, leaving time between start ups and it worked fine. Today it’s messing up again with nothing changed.

I don’t have a different graphics card, but I think that has to be my next step. I’ll have to but the cheapest $30 GPU on Amazon to test it. I could order a new $500 motherboard to test it, but then I might have to return it, which is not a nice thing to do lol.

Is anyone in the LA area that can help opt or recommend someone to help? I don’t really want to go the Craigslist route, so what’s the best way to find a professional to help? Maybe I can ask MicroCenter to recommend someone, they seem reliable…

is your data and time consistent or is it resetting to the default?
check the bios to see, as windows can automatically correct it so may not be apparent when your in the o.s.
if so its time to replace the battery…
when you get it to boot and work run something like ryzen ram checker. it will tell you if your ram has been switched back to 2133 or what ever the none extended profile is.
if so also a sign that the battery needs replacing.

why do i think battery?
asus doesnt allow an option to disable hpet in bios so its always on whether its enabled in windows or not.
this can drain the battery quicker typically 2-3 years quicker.

as you added more ram. check your interleaving settings.
you may have to change it to a specific handler

when you moved your gpu did you switch the bios/eufi peg mode to tell the system to look on another pci-e slot for the card?. code 94=cant enumerate the gpu meaning it cant see it.
i know. but sometimes we forget stuff.

if none of thats it then it sounds like the nvme has damaged more than just itself. :frowning:

as for getting a replacement motherboard off bestbuy… i think that might be asking blood from a stone.

1 Like

After stripping down the PC and testing it component by component, the issue is the M.2 socket that must have gotten damaged when the SSD shorted in it. It’s strange that it would still work fine if I managed to boot into Windows. But it would trip BIOS most of the time and didn’t let it POST.

The thing that seemingly made it harder is that the issue persisted even if I would remove the drive from that socket unless I cleared CMOS while the battery was out. So it wasn’t enough to take the drive out and try rebooting again…

Now after replicating it several times I’m 99% sure it’s the M.2 port.
The good news is, I still have a third M.2 socket I can use for the same drive and it’s working fine.

Hmm, so this did not resolve the issue, or did it continue having issues?
I think it is not likely, that you could convince best buy, that their drive caused the motherboard damage. It might be worth to have the crushed drive replaced, but apart from that IDK. I would not assume that they would cover a new motherboard, sadly. Althougt, that is solely from what I have seen here locally, in Finland, and some videos (GN, etc) talking about issues with retailers.
In short, send them a request to get a replacement drive, and also tell that the motherboard died because of that faulty, crushed drive.

This could be possible in opinnion as well.
And just to confirm, you reinstalled the CPU into the socket. I am assuming nothing looked off, while you did that.

Based on this info, I would have to guess, that the issue is that the short happened with some of the data-pins, and caused some damage to BIOS. I think that might also cause the error 94, due to damage with that section.
Sorry say this, but this is my best guess. Again, I might be totally wrong, but that is sadly my best guess. In this case however, IDK if the Cheapo Amazon GPU is going to help.

@LukaLumen

Ok, I’ve tried almost everything people here suggested and I have a new theory. It’s very unusual, but I think it makes sense.

There might be a hairline crack somewhere on the motherboard that makes it not start up until it’s heated, the metal expands and re-establishes the circuit.
Or GPU or PSU or CPU, but I hope not lol

Every time I cold boot it fails with code 94, but if I leave it on for a couple of minutes and restart, it will POST every time. If I only do a restart it will POST every time. If the weather is warm (I’m in LA), it will POST. Only when it’s cold, especially in the morning, it will fail with code 94.

You can imagine this made it impossible to test because the results are random and depend on the temperature.

I re-connected all the cables and sockets twice, so it’s not a loose connection, it must be a hairline crack somewhere. It might have happened when the SSD shorted or when I installed something, even if I’m really careful with my stuff.

So yeah, that’s where I am and will be looking to replace the mobo :-/

Thanks again to everyone who tried to help!

1 Like

That’s an all to common PSU failure mode, or mobo damaged by failing PSU. In my limited experience, it gradually gets worse over a long period, until a day in winter when it struggles to boot at all.

Yeah, except the PSU is only 2 years old, a Gold version and also rock steady with the system on full load running Prime95 and Furmark, so I think it’s the mobo :frowning:

1 Like

I have the same problem as you do. Did you found a solution yet?

Probably PSU as mentioned above.

The 3970X can easily draw 400-450w when stressed. Add a 1660 super OC card and you are at ~650W. That is enough to pull a 750W PSU to their limit.

Hey, I finally think I “fixed” the issue.

I bought a new PSU, going from 750W gold to 850W gold.
The 750 was perfectly stable when loaded to the max with Prime95 and Furmark running simultaneously, so I didn’t think that would be an issue, but I tried buying the new one anyway. It didn’t help at all.

What did help is turning off Fast Boot option in BIOS! For now I have no issues, but it’s only been a few days, so let’s see how it goes.

The PC is not really booting any slower as far as I can tell and it’s all running well. I also don’t know why it helps exactly, but it looks like it does.

1 Like

Actually, nope. It’s been working fine for like a week and now it sometimes get stuck on POST.

Does anyone know a reliable person that I can pay to figure this out in LA area?