OpenSuse, why hast thou grieved me

I’ve said in other threads that for some reason I always end up wanting to install OpenSuse (I blame Bryan Lunduke’s subliminal messaging) and it always goes terribly. Well, I went for it again and I’d like to share this experience.

Let’s start with the install:
I boot from USB and surprise everything seems to be working fine but then the command-line goes weird and it never goes into graphical mode. This is a problem I’ve had before, the reason for why I gave up at the problem then is because I needed a workstation ASAP due to finals and didn’t want to figure it out. I figured it was a problem with having fairly new nvidia graphics card.
The fix? Simple enough: unplug my DVI & DP monitors, leaving only my HDMI monitor. ¯_(ツ)_/¯

So the os is installed and I’ve booted into it. I plug my monitors back in and… No picture. Unplug and restart.
Alright, it’s probably just a driver issue: time to get NVIDIA graphics. According to the OpenSuse Wiki I can easily use YaST2 to add a nvidia repo and it’ll automatically select the correct driver version. Wonderful, let’s do that: oh wait the repo doesn’t appear in the repo list.
Ok, no problem, GUI is for suckers, let’s do this via cli:

$ zypper addrepo --refresh NVIDIA

bash: version: No such file or directory

Oh. Very well then, maybe an update will fix it, eh?

$ zypper update

Retrieving repository 'openSUSE-20170725-0
Empty destination in URI: hd:///?device-dev/disk/by-id/scsi-1PHISON_USB3-part2

See, as I’m typing this out I realise I’m a complete moron and I was too quick to remove the USB but whatever man windows 4 lyf. ;_;

EDIT 0: I have indeed figured out that the bootable USB stick is in fact a repo that it checks, the error I was getting was just letting me know that that repo wasn’t functioning and it wouldn’t be checked. The problem, however, still remains. I will continue to edit as the story unfolds.

EDIT 1: So I actually decided to read the wiki page I was following and it turns out the easy way is only for OpenSuse Leap, which won’t work for me since I’m on Tumbleweed. Ok, no problem, the “hard” way is just like how I did it in Fedora, can’t be that hard, right?

20 minutes later


Shoutout to this guy for telling me to blacklist noueavu first:


I warned u dawg. I warned u about Lunduke.


I’m holding him personally responsible for edit#1! Pitchforks and torches at the ready!


Tumbleweed + Nvidia proprietary drivers = NO NO.
Just to be sure, you do know that every time you update the kernel you will have to compile the drivers again, right ?

and by the way by default installing the nvidia drivers should block the nouveau drivers, that’s why it is as a second step IF it doesn’t work as expected.

1993: “How can I play DooM if I can’t even get the drivers to work!?!”

2017: “How can I get a graphical environment on my new OS install? By messing with drivers?”

2041: “Dang it, everybody said I was born blind! But really, all the doctor forgot to do was install drivers for my graphics card!”

It’s a tale as old as time, and it will continue.
Glad you found the issue kek

1 Like

I’m honestly not bothered. The performance gain vs. the time loss is worth it imo, especially since I do a fair bit of gaming as well as video editing (although i edit less now since I only ever learned on sony vegas and kdenlive hates me).

If that’s a reference to what I said I can’t quite explain what I meant. When I installed arch a while back I had to do some finagling for it to work with my gpu, I figured it was the same issue. Turns out I was way off.

Don’t worry 'bout it, there’s always some bizarre finagling that has to be done, I think I got what was going on

1 Like

Another ludicrous display of failure: I needed to get Discord up and running so I spend roughly 17 minutes getting Alien to work on OpenSuse, finding some user repositories, make sure everything is in order, install, remove repo since it hasn’t been updated and if the program works no need to risk unmoderated updates and HEY WOULDN’T YOU KNOW IT I forgot that Discord has a tarball which I’ve already used in the past to install Discord on Fedora. >:(

At least it was a neat learning about OpenSuse’s (for lack of a better term) AUR equivalent. At this point though I’ll probably just wipe the drive and install Gentoo, at least it’s not cursed. (is joke my OpenSuse adventures shall continue)

Also another problem I’m running in to: getting firefox 53+ on OpenSuse from a repo. Right now I just downloaded a .tar from Mozilla and uninstalled firefox. For this one I’d appreciate advice if you guys have some ideas.

EDIT: I’d like to point out all of this nonsense happened to me on DAY 1 of install. If this thread doesn’t turn beginners off OpenSuse idk what will. Go back to Slackware you milk-drinking n00bz.

I love my Slack, I like milk too… :stuck_out_tongue_winking_eye:

1 Like

Here you can find the Mozilla repo for tumbleweed which has 54.0.1.

if this is true, that’s some pisspoor decision making from a distro.

But seriously, is there anything these “”""“workstation”"""" distros do that Ubuntu derivatives can’t? I will never understand why people, upon needing a Linux distro that “just works” NOW, don’t just install a *buntu flavour and get going. You can be Hip McDistrohop AFTER you’ve done whatever work you needed to get done fast.

Don’t get me wrong you can have tumbleweed with Nvidia it’s just somewhat tedious to compile the drivers after every kernel update …

You can do almost everything except learning for a specific platform. Because if you have to use SLES or RHEL on your workplace and you want to learn more stuff in the free time it is recommended to use opensuse or fedora/centOS.

Also there are some programs that are nice like :
Of course it’s nothing unique …

i hadn’t realised it was replying to yours until just now, sorry about that. I was mostly referring to the OP and this statement.

unless it’s a final on some server admin course or some such, I would’ve just fired up something like Ubuntu to get past that “I need an OS right now that works” phase.

… gotta black list that legacy stuff.

Also related…

1 Like

Thats technically not true.

Tumbleweed is a very uptodate rolling release. This means that every time the kernel updates, the graphics drivers breaks.

This isn’t an opensuse problem, this is a rolling release model problem.

Distros like arch have special tools and scripts to make your life easier, and the same tools exist for opensuse, but they are a bit wonky.

This is as complicated as reinstalling the nvidia drivers gets.

Log out

Control + f4

su - then enter your pass word

telinit 3

su - enter your pass word.

sh /path to your nvidia

done, restart your computer. It takes less than a minute to do this.

Dude, discord works fine for me.

You are making this wayyyyyyy harder than it needs to be.

Thank you kindly, good sir.
Quick question: aren’t these additional repo’s supposed to be available to add in your repo list through YaST? When I try to add a repo under “Community Repositories” I just get Main Repository Sources and Debug, no others listed. I am, however, able to add a repo using a direct URL, luckily. It’s just a tad inconvenient so I’m looking to get the other thing to work.

The problem was that my windows install decided to break so I figured it was as good a time as any to make the 100% switch, I just needed something to get me as far as github, let me SSH into my webserver for a web developing course and run a windows VM for powershell & cisco packet tracer (didn’t feel like installing it on linux, even if it was just a temp install). Saying that I “needed a workstation” was probably not the best way of putting it. I just needed something that would work and I’ve never had a serious problem with Fedora, unlike Ubuntu. It also helps that I had a usb stick that had Fedora on it ready to install.

To be fair to Ubuntu, I’ve never had a real problem with any distro that hasn’t been due to my own incompetence, however, Ubuntu just ran really badly on my laptop, idk why. IT WAS PROBABLY JUST THE GRAPHICS DRIVERS GAISH. Tried both Unity and Gnome, both ran really poorly but Mint, Fedora and Arch all worked flawlessly.

Yeah I did notice that option, I’m still just carefully approaching that thing. Though I did notice everything seems to be tested and stuff. I’m always just cautious grabbing user repositories (he says in the same post where he’s asking how to add community repositories lol) where a bad update can screw me over.
I did actually install packages from the AUR willy-nilly but I took some time to get used to it before I did installed packages carelessly.