OpenGL 4.6 downgrades to 1.1 when both Nvidia GTX 1660 Ti and Intel UHD 630 drivers are installed?!?


This happens on an MSI laptop (GL75 9SD-072) running Windows 10 Pro 64-bit (20H2, Build 19042.928).

If either Intel driver (igfx_win10_100.9466) or Nvidia driver (466.11-notebook-win10-64bit-international-dch-whql) is installed, then it’s OK - OpenGL is 4.6. However if both drivers are installed, it doesn’t matter the order of installation, as I’ve tried both, the OpenGL is 1.1.

When I uninstall either Intel or Nvidia driver, OpenGL would return to 4.6. Of course if I uninstall both Intel and Nvidia drivers, OpenGL would be 1.1. The uninstallation was handled through Display Driver Uninstaller (

I verify OpenGL version and basic functionality with GPU-Z (2.38.0) and GL-Z (0.5.0), respectively.

I’d like to have the OpenGL 4.6 working with the latest graphic drivers from both Intel and Nvidia.


Have you tried using any software that uses OpenGL, I doubt anything even half way modern will not work on 1.1 so if anything works at all then the version is being misreported.