Oculus Quest 2 operating as USB 2.0 on USB 3.2 Gen 2 type C 20Gbps port

I’m trying to use the usb type c front panel port on my x570 aorus ultra board. I bought a gen 3.2 gen 2 type c 20pin to type c male cable to connect to the motherboard type c port below the 24pin. Then I even bought the way to expensive oculus high speed link type c to type c cable. Still only recognizing it as usb 2.0. I could try the type c port on the rear io…but I really want to use the front panel type c because IT SHOULD WORK! Do I need to enable usb 3.2 gen 2 somewhere in the UEFI/BIOS? I tried looking for this setting and I found F_USB31C with options to set to Auto, Gen 2, or Gen 1.

I would make sure that its working on your motherboard by hooking up the rear IO first. From there update Drivers, Firmware, BIOS, etc. Changing the UEFI option may fix the issue.

I checked the Gigabyte Manual and the header does support USB 3.2 Gen 2. So if doing the above does not fix your issue then your cable that came with your case could be faulty or the Oculus cable is. Only way to to test it would be to get another device that utilizes the USB 3.2 Gen 2 speed.

2 Likes

be aware type c is the physical plug type not the usb protocol standard

it is entirely possible to have a type c port run usb 2 or even earlier

this also extends to type c ports in your case. usb 3.x cabling has higher spec requirements. unless it is directly attached to the motherboard all bets are off.

Yeah nothing seems to work. I spent literally 5 hours yesterday plugging and unplugging usbs trying to isolate the gen 3 devices and get them to operate at gen 3 speeds. I’ve tried updating bios, reinstalling chipset drivers, disabling global c states, adjusting usb settings in windows power plan, disabling legacy usb in bios, just about everything I could find on the internet as a possible solution. I’m getting the feeling this is just some kind of anomoly with ryzen and perhaps gigabyte boards in particular. I thought maybe i just had too many usb devices plugged in because I was using every usb port on the back of my x570 motherboard. But that shouldnt matter right? I did try unplugging every usb device that I could and leaving only the oculus on the 3.2 gen 2 type c it still locked to usb 2.0 340MB/s…instead of 20GB/s. Honestly one of the most frustrating things Ive ever encountered in diy pc.

If this is helpful I have gigabyte x570 aorus ultra, 5900x, 1000W 80+ titanium psu, 3080ti…idk what other hardware specs would be helpful. Also running wondows 11 currently but I dont think that should matter.

What case are you using? (because of the front panel). Have you tried a usb A cable with one of the usb 3 ports on the back?

I have an aorus elite x570 with 3700x and it works fine with my quest 2, but ryzen seems a bit iffy with usb.

For what it’s worth i’m running Ryzen on a gigabyte board (previously an asrock) with the oculus cable and haven’t had issues.

Current mobo is a X570S Aorus Elite AX
Previous was an X470 Taichi

2700X at the moment (in both boards)

And yeah, i’m using the type C port on the back directly attached to the motherboard. The case cabling for type C… depending on case who knows what it is. Might have a type C plug on it and be shit tier USB “full speed” or some shit (which case is it?)

Its a Yuel Beast Designs Atlass II so there is no front io. I’m using a linkup 20GB/s usb 3.2 gen 2 type c cable that I bought on amazon plugged into the F_USB31C header just below the 24 pin on the board. But I have also tried the type c rear io port on the motherboard and still no luck. I can buy like a high speed usb hub on my way home and try to clear out all the usbs I have going to the back of my board currently so that maybe the board stops mixing 2.0 speeds with 3.0 devices? I can also return my oculus cable and try a new one. Also might just say screw it and try a fresh windows install. I have tried uninstalling oculus, deleting all app data files, and reinstalling. That didnt work either.

It is a long shot but ryzen motherboards that support PCIe4 and CPUs that enable that, can mess with USB

In my case it is just full dropouts of the USB various USB ports under certain circumstances.

I don’t know if it can half cause problems in that it does not drop the port momentarily but keeps working just at a lower speed.

For note, there are bios updates that “fix” this though none have ever worked for me so I have given up. The only other full fix for the USB is to disable PCIe4 and force 3 speeds.

1 Like

Yeah i think ive heard that before. I am not sure how long this has been an issue for me because the only time is bugged me enough to look into it is right now when I’m getting 340MB/s on that VR type C cable instead of 20GB/s. Other than that I have never noticed any USB issues. I dont play VR that much its probably not the end of the world but it is super duper annoying to say the least! Probably wont try pcie 3.0 because I have windows install on a 2tb 4.0 drive that cost too much money not to use in this system lol. Ill try resetting defaults in bios and working through it again tonight with a usb hub or 2 for other devices and a new oculus vr cable.

Has anyone used a USB tree software or can explain better how to use it to identify or solve any of these issues?

Welp… reinstalled windows. Enabled every setting that could pissibly help. Tried working through everything with oculus support again. Literally just cant get gen 3 speeds on an oculus cable on this x570 board. Nothing left to do but wait for a class action lawsuit at this point. Or build an intel system…?

It is a terrible solution, but… Just to try and actually work out what the problems is, did you try disable PCIe 4 in the UEFI and force PCIe 3 speeds?

It is a super long shot, and the problem sounds different to the typical one that causes but it would be an answer and AMD apparently want to fix it… Apparently.