NZXT hue+ has gone back into bitch-mode

//edit : working again now, and i did absolutely nothing. ghost in tha pc.

Initially i ran into some issues with my hue+ and cam software not working as they should (not all modes available, losing connection)

Then i fixed it, or atleast thought i had fixed it, after a clean install of cam and drivers, and connecting the hue+ with a micro usb to usb 2 cable to the mobo IO panel instead of using the wonky cable nzxt gives you to connect to a usb port on your motherboard.
It then worked fine, i could pick all settings, hue+ responded correctly...

But last week it all of a sudden stopped applying the color scheme i had on CAM, though it is still recognized as hue+ in CAM.

What it does is it starts off with standard white on the rgb strips, then i go into cam and pick my scheme....no leds light up anymore (hue+ light is on and it is recognized in cam).
So then i disconnect the usb cable and the power cable, plug them back in, white leds again, pick a color in cam, no light, repeat, repeat....

What i don't get is that it was working fine all this time and now all of a sudden, without changes to CAM, it is giving me this crap again.
Might replace the micro usb cable AGAIN. But i doubt it's the cable that's wonky (the one nzxt gives you IS WONKY).

Or maybe get another micro usb to mobo usb cable instead of using the IO....
Or uninstall cam and re-install it AGAIN.

And even then, if i get it to work again....how long?

Was wondering if anyone else here has had issues with hue+ or other hardware they use CAM with ?

Is it an issue with hardware or software, both ?

When it works, the hue+ is a great little device for fancy lighting
But more often it doesn't work and it's just a pricey white led strip kit...... frustrating.

Yeah I had lots of problems with mine. It would flash random colors whenever it felt like but the real problem is the software is absolute trash. I ended up returning mine and now that Asus motherboards naively have 5050 RGB LED headers, I just use the Asus Aura app and it does what CAM does functionally without using 2GB's of RAM and being unresponsive and dumb.

A 1m LED strip cost me $12 + a motherboard I already needed anyway.

This post was flagged by the community and is temporarily hidden.

I had a Grid+ and CAM was an absolute nightmare, I cannot hate that terrible piece of software more. I cannot recommend staying away from anything that requires CAM any more, I could not stand it.

Aura is nice idd, but a new mobo isn't gonna happen anytime soon. Plus it has red highlights, price is good, but the krait was cheaper and color neutral. Perhaps i would've gone the aura route had i known cam was such a bitch. Kyle of awesomesauce network did an in depth review on it, it seemed good....perhaps he was lucky enough to not have any issues, fairly sure the dude is honest in his reviews.

But eh, it's been working fine this week, maybe it will get its pms again in a few days... :p