Return to Level1Techs.com

Nvidia Tesla vGPU on vSphere

Hi there
I am trying to get my Tesla P4 GPU working on my ESXi host 7.0U2.
I was at the illusion that ESXi would be able to use it just “out of the box”, and it did see the card as a GPU, but it reported 0GB Memory and when I tried to add it to a VM it showed no profiles…
500 reboots later and Nvidia vGPU drivers installed on the ESXi host I can now see the 8GB Memory (I have disabled ECC on the card).
And I an even see profiles when I add it to a VM.
Sadly when I try to start the VM, it tells me “No host is compatible with the virtual machine” when the host is in a cluster. If I take it out of a cluster for it self, it tells me “The operation is not allowed in the current state of the host”.
If I remove the vGPU I can start the VM, no problems.
I have of cause reserved the memory of the VM. (16G)
The host is a HPE DL380G9 with 128G Memory, dual CPU.
And SR-IOV is enabled in the BIOS.

I have also tried just to create a PCI-Passthrough on the PCI device, but even that will not work… I think some ESXi drivers gets hold of the card first, which makes it unable to startup the VM. Because the GPU is still shown under Graphics in ESXi even after I created the PCI-Passthrough…

My simple plan is just to use the card on a few Windows VMs, or even just assign all of it to one single VM if possible.

I am aware that if I wanted to use VMWare Horizon I would need some extra software from Nvidia (license server) but of cause I do not have any valid licenses with Nvidia…

Any suggestions are very welcome… I still have 14 days in which I can return the card :wink:
I mainly bought it because it fitted nicely in one PCI slot :wink: Also I do not require insane performance… (no gaming here) :wink:

Thanks!

For passthrough of a whole card to a VM as a generic PCIe device you do not need additional software. But you need software from NVIDIA to use vGPU whether you use Horizon or not. Where did you get the vGPU drivers?

I registered for a trial to get my hands on the drivers.
I didn’t install the license server etc. maybe that’s what’s missing?
I was able to pull the ESXi server out of vSphere, and assign the whole card to a VM via Passthrough… so I guess it’s a vSphere issue, and most likely a license server is needed which is sad.
But I guess I was verified with my tests, that a Tesla card is not much use on a single VM in regards to remote desktop experience editing video etc… I guess I will need a “real” graphics card for that?

The license server is needed for the guests. For vGPU you have to use a special version of the driver which checks out licenses from the license manager, and if it can’t be contacted, isn’t configured, or has no available licenses, the card will be throttled. IIRC the driver in the guest also has to match the version of the vGPU VIB installed in ESXi. When you use the generic NVIDIA driver with generic PCIe passthrough that is not necessary.

If you have a trial license you should be able to get all the pieces working long enough to evaluate it, but if paying for it is not an option it’s probably not worth the time to troubleshoot.

Hi there, did you get this resolved? I am getting similar message with A40, regarding the state of host. If I boot it off the ESXI it works fine. I cannot boot it from vCenter.