Now Nautilus is broken

(nautilus:16029): Gtk-CRITICAL **: Error building template class 'NautilusToolbar' for an instance of type 'NautilusToolbar': .:193:46 Invalid property: GtkScrolledWindow.max-content-height
Segmentation fault (core dumped)

So I can't open Nautilus, here is the output from launching it from the terminal. I am running OpenSUSE Tumbleweed.

When is the last time you updated OpenSUSE Tumbleweed? I'm on it as well.

Last night right before this problem started.

I don't seem to have this issue and I updated just today. Trying asking in /r/opensuse?

I also can't open the gnome settings app.

Have you tried rolling back on Snapper? That may help.

Well I am kinda new to OpenSUSE and this is the first time I have heard of snapper, So I don't have any images.

Hmm, I really don't know what would have caused this issue. My best advice is to ask on /r/opensuse or the mailing list / irc. People actively help in those IRCs and are more knowledgeable than me.

press Ctrl + Shift + F1, and this opens up a TTY sesssion. Log into your account and manage your system via CLI. Suggest you rollback the version of nautilus using zypper or yast cli.

1 Like

I can open a terminal just fine.

The best bet is to either ask for support or start rolling back packages like Dynamic_Gravity mentioned.

So it worked for nautilus, but not gnome-control-center it still has errors.

[email protected]:~> gnome-control-center
gnome-control-center: symbol lookup error: /usr/lib64/libwebkit2gtk-4.0.so.37: undefined symbol: gdk_wayland_display_get_type

Then what's the problem? Are you having trouble rolling back the packages?

You can use zypper info -t type name to find information about the packages in question.

type = package type
name = name of what we are querying.

Package Types

  • package
  • patch
  • pattern
  • product

I rolled back nautilus and now it works just fine, Now I can't open the Gnome setting app. I tried rolling it back, but it still doesn't work.

So I have also tried reinstalling the control center and that didn't work. I am really wondering what to do. I guess I will make another thread about this problem.

It sounds like there's an inconsistency in a file somewhere.

Let's try verifying the packages, just to be sure:

$ sudo zypper ve

This will verify the dependencies are all handled properly. If you could share the output with us, that would be perfect.

[email protected]:~> sudo zypper ve
[sudo] password for root: 
Loading repository data...
Reading installed packages...

Dependencies of all installed packages are satisfied.

Alright... Let's see here....

It looks like, from the error message, you're having a version mismatch on your packages.

Let's try a full upgrade:

sudo zypper dup

Sorry nothing changed.

Hmm, install Nemo if you can, its a pretty good alternative. See if Nemo works to just confirm you haven't got some bad library somewhere.

I was on Gnome Opensuse but it lacks allot of love that their KDE desktop receives, so went back to KDE. Gnome has had its features stripped out so much over the years that it becomes VERY hard to customize, same with Nautilus. Sure extensions are nice, but it seems like a sluggish way to introduce basic customization...

PS. Coincidentally I ditched the Gnome desktop for similar reasons, broken library files.. still a bit myth-ed as to how it happened but basically everything started not working.