Not Booting!

My recently built PC had been working fine, latest drivers installed, everything, however, it had been acting strange. It wouldn't boot correctly the first time I turned it on, I would always have to turn off the power supply and turn it on again, and it would work. Recently though, my machine just says "reboot and select proper boot device or insert boot media in selected boot device and press a key."

In the bios, either the motherboard (asus crosshair v formula-z) doesn't recognize my two drives (ocz vector 128gb and seagate barracuda 2tb) or they both stopped working... at the same time. I'm new to the computer game and need help, thanks.

Clear your CMOS

find where your CMOS stands are and take the piece off and switch it over the the left (or right) and then switch it back



The CMOS can be found easily in your motherboard manual and it will give you instructions

also make sure that all your cables are installed properly to your PSU

Which PSU are you using?

Seasonic m12 II 750W

also make sure that no switches on your motherboard are on the on position (and "GPU BOOST" or CPU BOOST switches)

as these can sometimes cause issues

Thanks for the help

No problem, mate.

That didn't help, in the bios it doesn't have the drives listed

Are your HDD's properly connected to power and their sata cables?

I seriously doubt that both your HDD's failed at precisely the same time. Try different Molex ports in your PSU for your HDD's

Idk, I tried switching the SATA power cables, SATA data cables. When I plugged in the hard drive, I heard it start to run. My motherboard has a CMOS button on the rear I/O, I don't know what to two with that.

Does your PC beep at all when it turns on?

Are all your other components working correctly?

Have you tried only connecting the HDD with the OS?

No beeping, yes, my PC had been working and it handled far cry, crysis, and bioshock very well, no I'll try that

Didn't do anything. 

Well that's just odd.

You don't happen to have another computer in which you could test the HDD's do you?

Nope. I heard the hard drive (not the SSD obviously) start to whir when I plugged in the SATA power

I hope you're not hotplugging the HDD man

that's no good

turn the PSU off, unplug the PSU from the wall, plug it back in, try it again.

No, I didn't plug it in while the PSU was on, I heard it start when I went in to the bios and turned e computer on. I'm trying that anyway.