No Sound HDMI (Tried Ubuntu, Mint, Debian, Manjaro)

I’ve been wanting to make the full switch to linux on my laptop and the only thing stopping me is when I plug it in to my TV with HDMI, I can’t get sound. I’ve tried the distributions in the title, including different versions of ubuntu (14, 16 and the latest.) I’ve updated and installed proprietary drivers since it’s an Nvidia card. I’ve tried pulse audio, alsa and modifying both with a few different edits I found on forums. None of it works. I hate saying but it works fine on Windows 7, which I dual boot.

In the pastebin below, I’ve did a lshw on Manjaro with info about the laptop. I’ll also include an Amazon link to the laptop for basic info. Another thing to note is Manjaro is on USB but the other distributions, I did a full install to HDD, still no sound. I didn’t want to take the time to install Manjaro since sound didn’t work form the USB, I assumed it wouldn’t with full install.

https://pastebin.com/WDtwDB38

Your lshw results suggest you’re using the nouveau driver rather than the nvidia proprietary binary blob driver. Their feature matrix does indicate that the 1060 should have HDMI audio support, but to make things simpler let’s not get into that, you’ll have a better experience with their drivers rather than the open source ones. Can you post the lshw output from another install, with the proprietary drivers loaded?

In general, driver issues aren’t unique to distributions, but instead to kernel versions. In the future, keep in mind that it’s probably a waste of time to try another distribution — your first instinct when hitting a driver issue should almost always be to try it on the newest kernel you can get your hands on.

1 Like

I’ve installed the Nvidia drivers and here is the new lshw output.

https://pastebin.com/q7fpbDpu

I also noticed you said trying the newest kernel available. I’m running 4.18.5-1. The newest available to me is 4.19rc1.0831.g42 but it’s listed as experimental so I haven’t tested it yet.

Can you post the output of aplay -l?

2 Likes

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

did you boot Manjaro from USB with non-free drivers option?
that should load nvidia driver rather than nouveau

does pactl list cards show any profiles for hdmi?

1 Like

I’ve installed Manjaro from USB to my SSD. It started with nouveau and I updated to Nvidia with Manjaro Hardware Detection.

It does not. Under ports it only shows this.

Ports:
	analog-input-mic: Microphone (priority: 8700, latency offset: 0 usec)
		Properties:
			device.icon_name = "audio-input-microphone"
		Part of profile(s): input:analog-stereo, output:analog-stereo+input:analog-stereo
	analog-output-speaker: Speakers (priority: 10000, latency offset: 0 usec)
		Properties:
			device.icon_name = "audio-speakers"
		Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo
	analog-output-headphones: Headphones (priority: 9000, latency offset: 0 usec, not available)
		Properties:
			device.icon_name = "audio-headphones"
		Part of profile(s): output:analog-stereo, output:analog-stereo+input:analog-stereo

This seems relevant, but frankly seems a bit over my head:

I was also able to duplicate your findings on my Nvidia laptop, i.e. aplay -l does not display any HDMI audio output. lspci also shows no audio subdevice on my GTX 1050 Ti, unlike the 1050Ti in my desktop. Perhaps the Intel audio device handles HDMI audio - Optimus laptops are pretty squirrelly.

1 Like

listing of ports rather than profiles doesn’t help
but doubt it will get anywhere looking further there

It sounds like you used mhwd commands to install a driver, rather than the Manjaro Settings Manager gui,
mhwd --listinstalled will confirm what driver(s) currently installed

Suggest you try booting Manjaro from live USB with non-free drivers option
check in aplay -l again to see if any sign of hdmi
and get information on GPU and driver with inxi -Gxx

1 Like

@nikgnomic I was mistaken when I said MHWD. I didn’t use that, it was the Manjaro Settings Manager. I thought the were the same thing.

This is the output from the USB booted Manjaro with non-free drivers:

[[email protected] ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

[[email protected] ~]$ inxi -Gxx
Graphics: Card-1: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: nvidia v: 396.51 bus ID: 01:00.0
chip ID: 10de:1c20
Display: x11 server: N/A driver: nvidia resolution:
OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 396.51 direct render: Yes

I went ahead and ran mhwd --installed on the SSD install and the output was:

[[email protected] ~]$ mhwd --listinstalled

Installed PCI configs:


              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI
     network-r8168            2016.04.20                true            PCI
      video-nvidia            2018.08.09               false            PCI

Warning: No installed USB configs!

I plan on giving some of the info from @imrazor link sometime today. We’ll see how that goes. Thank you for all the help so far!

I tried following a couple things from the linked post by @imrazor.

https://bugs.freedesktop.org/show_bug.cgi?id=75985#c27

I get this error when trying to make the file:

[[email protected] nvhda-master]$ make
make -C /lib/modules/4.18.5-1-MANJARO/build M="$(pwd)" modules
make[1]: Entering directory ‘/usr/lib/modules/4.18.5-1-MANJARO/build’
make[1]: *** No rule to make target ‘modules’. Stop.
make[1]: Leaving directory ‘/usr/lib/modules/4.18.5-1-MANJARO/build’
make: *** [Makefile:13: default] Error 2

Following this post, https://github.com/hhfeuer/nvhda I get the same error:

[[email protected] nvhda]$ make
make -C /lib/modules/4.18.5-1-MANJARO/build M="$(pwd)" modules
make[1]: Entering directory ‘/usr/lib/modules/4.18.5-1-MANJARO/build’
make[1]: *** No rule to make target ‘modules’. Stop.
make[1]: Leaving directory ‘/usr/lib/modules/4.18.5-1-MANJARO/build’
make: *** [Makefile:13: default] Error 2

I tried googling for “no rule to make target modules” but didn’t really find anything, at least that I could understand.

I’ve been looking around the interwebs about this issue, and found the following thread. http://www.tomshardware.com/answers/id-3540730/hdmi-audio-monitor-speakers.html

An interesting quote from that thread is here

The fact that you’ve got a recent Nvidia GPU in your laptop (965m) strongly suggests this is an Optimus laptop. If you installed the regular Nvidia drivers and are trying to pipe video out to the Nvidia HDMI audio device, it won’t work because the Nvidia GPU is not hooked up to your HDMI port. The Intel GPU is (on 99.9% of Optimus laptops).

However there are some inaccuracies in the thread, like a note that you have to use notebook OEM provided drivers to get Optimus support. So take the whole thing with a grain of salt.

The upshot is that the Intel GPU may handle the HDMI audio.

1 Like

The only reason I don’t think that is an issue is because it works fine on Windows. It seems the problem linked in your post is on windows and I don’t have that issue.

I still haven’t sold this issue so I’m wondering if you guys know of another forum, maybe for arch or manjaro that would be good to post this too. I’ve already tried linuxquestions on reddit but no luck there.

1 Like

Here’s a relevant thread.

https://bbs.archlinux.org/viewtopic.php?id=207085

Basically, there’s no point in trying audio in any of the apps until you get HDMI to show in alsa, and in aplay -L and aplay -l and until you get some noise through with speaker-test -D some_device. Your kernel should contain drivers for Intel hda that support alsa.

What laptop is it?

1 Like

I added it in the OP but here is the link to my exact laptop. The only difference is I installed a 120gb M2 SSD which Manjaro is installed to.

I do understand that the sound won’t work until I get linux to actually see the HDMI audio device. This is not an Optimus laptop though so the HDMI port should be connected to the GPU, not Intel. I may be wrong about the second part, but it is not an Optimus laptop for sure.

I’m looking in to trying the script from this post at the moment but I’m not exactly sure how to set it up and run it. I assume I need to save it as an .sh file and set it to run on startup. How would I get it to run on startup?

Another thing to note is when I run sudo journalctl -b 0 | egrep 'HD’ the outut is this:

[[email protected] ~]$ sudo journalctl -b 0 | egrep 'HD'
Sep 12 11:01:37 Linux kernel: DMAR: DRHD base: 0x000000fed90000 flags: 0x1
Sep 12 11:01:37 Linux kernel: DMAR-IR: IOAPIC id 2 under DRHD base  0xfed90000 IOMMU 0
Sep 12 11:01:37 Linux kernel: DMAR-IR: HPET id 0 under DRHD base 0xfed90000
Sep 12 11:01:37 Linux kernel: usb 1-4: Product: USB2.0 HD UVC WebCam
Sep 12 11:01:37 Linux kernel: input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input8
Sep 12 11:01:38 Linux systemd[1]: Starting nVidia HDMI Audio Fixer...
Sep 12 11:01:38 Linux systemd[1]: Failed to start nVidia HDMI Audio Fixer.
Sep 12 11:01:38 Linux kernel: uvcvideo: Found UVC 1.00 device USB2.0 HD UVC WebCam (13d3:5666)
Sep 12 11:01:38 Linux kernel: input: USB2.0 HD UVC WebCam: USB2.0 HD as /devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/input/input21
Sep 12 11:03:52 Linux gcr-prompter[9345]: Gcr: beginning the secret exchange: [sx-aes-1]\npublic=M1xbH5DJ9LniFs3941qpQe97Q+3ktOR8xPE1kxbGwrFvwDhkdeulzaI5IRGgCMik7iuHGC/35wa5lRq356tRt0yBePjlGK78NF8ySukNtijXPt/YEGvbKtWFniHSd/weAPzTGO3dsRFTt0QKowT/jG0CFKipEkCd7ewuglYFLwXlXYk693roRUagrv3wQY1q+LS9T/D8A2pDsDtjVC+0Br3bLp997HDwI9sdJUGo0huz114acrFE5AejnpFTZ0mc\n
Sep 12 11:03:57 Linux gcr-prompter[9345]: Gcr: sending the secret exchange: [sx-aes-1]\npublic=M1xbH5DJ9LniFs3941qpQe97Q+3ktOR8xPE1kxbGwrFvwDhkdeulzaI5IRGgCMik7iuHGC/35wa5lRq356tRt0yBePjlGK78NF8ySukNtijXPt/YEGvbKtWFniHSd/weAPzTGO3dsRFTt0QKowT/jG0CFKipEkCd7ewuglYFLwXlXYk693roRUagrv3wQY1q+LS9T/D8A2pDsDtjVC+0Br3bLp997HDwI9sdJUGo0huz114acrFE5AejnpFTZ0mc\nsecret=iLAYoR6WjTCCmSQjBBAbgA==\niv=j43nsp4DTwwlK426/5JBeg==\n

Note the lines that say:

Sep 12 11:01:38 Linux systemd[1]: Starting nVidia HDMI Audio Fixer…
Sep 12 11:01:38 Linux systemd[1]: Failed to start nVidia HDMI Audio Fixer.

I’ve did some googling but can’t find anything about nvidia HDMI audio fixer… Any idea what this is?

Sadly, I still have not found a solution for this. Something so simple like audio via HDMI turned in to 20+ hour issues that seems almost impossible for me to solve. This was the only thing keeping me on windows and it looks like it has won. Going back to Win 7 for now, maybe this will be fixed by the time Microsoft stops support for Win 7.

Thank you all for taking the time to help me though!

If you haven’t already made the switch back to Windows, you may want to check this out:

This one talks about what to do if the HDMI audio output is missing and he makes some suggestions to re-enable it. I can’t try right now because I’m at work, but I’ll give it a shot on my Nvidia laptop when I get home.