NO SMT on TaiChi X470 w/ 1700x Kubuntu 19.04

SMT is set to AUTO in the bios v 3.2
if I boot to windows 10, I see 16 logical units

secure boot is disabled / never was enabled in bios

but in kubuntu 19.04

cat /sys/devices/system/cpu/smt/active

Architecture: x86_64
CPU op-mode(s): 32-bit, 64-bit
Byte Order: Little Endian
Address sizes: 43 bits physical, 48 bits virtual
CPU(s): 8
On-line CPU(s) list: 0-7
Thread(s) per core: 1
Core(s) per socket: 8
Socket(s): 1
NUMA node(s): 1
Vendor ID: AuthenticAMD
CPU family: 23
Model: 1
Model name: AMD Ryzen 7 1700X Eight-Core Processor
Stepping: 1
CPU MHz: 1972.547
CPU max MHz: 3700.0000
CPU min MHz: 2200.0000
BogoMIPS: 7400.04
Virtualization: AMD-V
L1d cache: 32K
L1i cache: 64K
L2 cache: 512K
L3 cache: 8192K
NUMA node0 CPU(s): 0-7

htop only shows 8

i am not sure how to enable it

there are no
in grub that i can find

sudo echo on > /sys/devices/system/cpu/smt/control
bash: /sys/devices/system/cpu/smt/control: Permission denied

cat /sys/devices/system/cpu/smt/control

everything else works fine.

not sure what else to try, kind of at the end of what I could google.
ASRock won’t talk to you about linux problems. At least me anyway…

any ideas would be appreciated


Have you looked in your uEFI to ensure that the SMT option is turned on? It could be possible that MS Windows ignores the configuration. Make sure it is set to On and not Auto or Off