No Keyboard input on remote KVM ASRock Rack X570D4U-2L2T

I’m experiencing a highly annoying issue with the Remote Control (KVM) option for the X570D4U-2L2T.
I’ll contact ASRock, but they haven’t bothered to respond to my previous ticket at all yet, so in the meantime perhaps I can find somebody with experience here.

After some initial issues getting IPMI to work, I managed to get it fully operational and Remote KVM was working fine. I did my BIOS settings using it, etc.

Yesterday I installed the rest of the hardware in the enclosure (some extra fans and swapped RAM and CPU cooling). Since then the remote KVM doesn’t fully work anymore: I get Video just fine, but nothing happens when I press any of the keys. I tried the virtual keyboard as well, no response.

I’m using the HTML5 Viewer. I tried various browsers (Chrome, Firefox, Edge), but it was working fine in Chrome before yesterday.

Is there anything that could explain this change? I went through all the settings, but I can’t find anything that seems relevant. The user has full admin and KVM access.