Return to Level1Techs.com

No internet connection on Ubuntu 18.04.3 LTS after update

Howdy folks.
After an update two days ago, my daily linux machine can’t get an connection, not even to my own lan. It can’t even connect to my pfsense router…
I’ve tried disabling the firewall but that didn’t help…
I remember there being 2 updates, 1 ubuntu base system, and one about some vpn? Though I don’t remember the specifics.
I’ve used openvpn in the past when connecting, and started using nordvpns own linux client a few weeks ago.
That didn’t give any problems though, but the recent update did.
Is there a way to see what updated recently, and possibly roll it back?

I’v solved my problem :slight_smile:
A bit of googling led me to go to /var/log/apt to look at the update history log. The recent updates was an Ubuntu base update, and an update to nordvpns client.
So I ran “sudo apt --purge remove nordvpn” and rebooted, and I now have working Ethernet again.
So I guess I’ll stick to openvpn rather than nordvpns client for the few times I need to connect to a vpn :slight_smile:

1 Like

There was some revent noise, about a setting changed in recent distro’s that effectively opened VPN users to MITM pretty easily. the fix for the problem could have caused the issue.
They ahev probably patched the client by now, if theat was the case.

It shouldn’t have affected you, but could have been an over cautious over-correction on Nord’s part, given theiur rep?..

But no-one else has mentioned it here, so way to go! Trend setter!

Well that certainly doesn’t sound good, though I haven’t heard anything about it till now.
I haven’t contacted nordvpn about it, I was mostly just annoyed I didn’t have an ethernet connection.

After purging their client, It struck me that it might have been the clients kill switch, which I had enabled.
But that shouldn’t be active when I wasn’t even connecting to one of their servers ?

I don’t know, just put an idea out there. Networking has always been “interesting” on Linux, either “just working” or not…

Yeah, my first thought wss: Crap, why doesn’t it work, and will I be able to fix it.

1 Like