No audio from movies served over apache when following a symlink

I’ve got a server with apache running on it. Sometimes I’ll put a movie in my web directory to watch it through a browser quick and dirty. Moving the files around/making copies got annoying so I started making symlinks (and configured apache to follow said symlinks). However, when I try to watch a symlinked movie I get the video just fine but no sound. If you download the file from the same link and play it through any other player the sound works. I’ve even opened the link as a stream in VLC and it worked just fine. I’m also seeing no errors about it in the log (/var/log/httpd/error_log). Seems like the built in Chrome player just isn’t having it. Any suggestions?

Have you tried moving that file into the webserver’s directory (cp, not ln -s) to verify that it’s the symlink that’s causing the issue?

Chrome’s web player has a tendency to not be happy with certain codecs, and you may be encountering that.

Sorry for the late reply. It was a codec issue. Thanks!