New Nitro+ 6900XT SE Upgrade Now Causing Audio Stuttering

Hey everyone. Don’t know if this is the best place for this or not, but Mods, feel free to move this if needed.

Got a strange issue here. Just got a gpu upgrade (EVGA 1080ti SC2 to Sapphire Nitro+ 6900xt SE) and now I have an audio issue that didn’t exist before. Any audio that plays for more than about 20 seconds develops what I can only describe as an occasional “hitch” or “stutter”. It’s like if you quickly hit pause then play on an iPod creating a less than 1 second interruption in the music and I can’t figure out why it’s happening.

I used DDU to uninstall all Nvidia drivers, prevented Windows 10 from installing its own AMD driver, then installed the recommended AMD driver from their site. Tested audio, still happening.

Updated the drivers and reset my audio settings to their defaults (using Voicemeeter for routing/mixing and an external dac). Tested, still happening.

Took Voicemeeter out of the loop and sent audio directly to my dac. Still happening.

Updated the Realtek driver for the motherboard’s audio somewhat out of desperation, still happening.

Anyone got anymore ideas?

Have you checked the Sound settings to see if it enabled the audio output to the hdmi/DP ports and trying to send it to the monitors?

It doesn’t look like it’s sending to the monitors, but I’m game to try just about anything at this point.

1 Like

I would try disabling the monitors listed in the Sound Settings control panel and have just the VMeeter outputs and dac output you need.

That didn’t work, but now that I have left my system on for a while, the MADIface USB diagnostic is showing a whole lot of errors. I’m gonna trace the cable and try another USB port

Have you tried hooking speakers or headphones directly to motherboard audio jacks?

I have not, but I’ll try that once I get off work.

I have also found that the direct HDMI audio feed to my main monitor (LG C1) also does it. Seems to be something in the Windows audio system, not the peripherals. Even the RME MADIface USB audio diagnostics tool is finding ongoing errors in the background without any audio playing. I’m at a loss for what is causing this.

I can say that when i was using VoiceMeeter going directly out or into my DAC, I always had audio issues with every Windows update. It would seem that with each update, MS couldn’t decide whether the default driver should be WME or any of the other audio drivers it can use. It’s possible one of those is funky.

You also might try dropping into an Administrator CMD window and running sfc /scannow, maybe something got corrupted at the OS level.

Well, I tried all the things but had no luck with any of it. Still getting around 1 stutter per minute. Finally decided to just wipe out this install of Windows and do a fresh from iso copy. 3 hours later on Win11 Pro and I only occasionally get a stutter while playing music/video. Didn’t fully solve the problem, but going from ~1 per minute to ~1 per 90 minutes is good enough for the moment. Was really thinking I may have a problem with this gpu since that was the only change to the system. Thanks for your help!

1 Like

That’s really odd that the GPU would cause it unless it’s causing the issue along the PCIe lanes, but that and the circuitry for the audio should not be related.

When looking at Task Manager, can you see a spike or dip in CPU/GPU when the stutter occurs? Could be a wierd power issue? So odd …

it’s not the AMD stutter bug is it?

@Pauld42 I never saw a spike actually happen but I know that even sitting idle, the running count of errors from the MADIface diagnostics continued rising. Now that I have done a fresh Windows install, it doesn’t happen often but usually does it when I’m loading or closing a program which could play in to that AMD stutter bug.

@electricLibrarian I know that it wasn’t that because I was on Win10 and had the TPM disabled in UEFI. Now that I am on Win11, the ongoing occasional stutters could be because of that. I’ll have to look in to that listed workaround. Thanks for that link!

1 Like

Update on this issue:

This seems to be a problem with the VoiceMeeter Potato software. Bypassing VM and going back to a direct out clears up the distortion and robotic sound immediately. I use VM to route my audio to both my monitor (LG C1 2021) and to my external DAC, while also having the use of a midi controller to simulate having a GoXLR.

While that problem is solved, does anyone have software alternatives I could try with same or similar function to VM? Preferably something with Linux compatibility for when Windows finally makes me mad enough to fully switch over?

Thanks for all the help everyone!

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.