New motherboard, new issue. Graphic card doesn't give out good signal(solved!)

It’s weird. I just changed my mobo for a crosshair dark hero. Reinstalled a fresh install of Linux just to be safe. Reinstated my VM setup like before. Tried Manjaro and easymode Ubuntu. My 6800xt is detected with lspci as used by vfio-pci. Last attempt i used Mathias hueber guide, step by step. The VM boot but the only video output i got is this. That was with my old virtual drive i had from the last setup. If I try to make a new win10 VM i just get a white page instead of the blue of a windows install.

The rig : 5950x
Asus crosshair dark hero
32gig of 3600 MHz ram
4tb sabrent nvme drive (for my VMs virtual drives)
1tb we black nvme (host)
1080ti (host)
6800xt (vfio)
Lvl1 KVM switch dp1.4 2 screens

The thing is, this config was working just fine with my crosshair hero, i upgraded to the dark because my GF MOBO crapped on us and i gave her my hero and got the dark. I did the same setup i always do… It’s the first time i got something like that, I’m flabbergasted…

Edit. At least i know it’s not my card that went dead after the change. I just tested it in gaming on a bare metal windows emergency install, still game fine. No issues on that front

Edit 2. I toyed around with the above 4g transfer and the resizeble bar option in the bios. With it on without the bar, I get to the KVM splash screen but black screen after… With it off all the way, I still got the screen but black screen again… I double checked, IOMMU is on and srvio too. If i let it run, there is activity in my pinned cpus, just no signal.

Final edit, solved by Wendell, for some reason CSM enabled with resizable bar worked.

Toggle csm and resizable bar one at a time and see what happens


I’ll try that, if I can find it :slight_smile: thanks Wendell!

Holy mother of kernel… Wendell i loooooooove you. Enabling both csm and bar made it work!!! I told myself, try both then toggle one off the switch but both worked!!! How the hell did you know that CSM would interact with a virtual machine??? I mean csm is for the bios, not the VM.

Pardon my french but damn! Wendell to the rescue!!! I feel touched by the voice of God! Lol. Thank you thank you thank you!!!