New build not working noting shown on screen

Ok so a few weeks ago I sold a friend my i5 3550 and mobo. It was out of my bedroom PC that barely gets any use so it seemed a waste just sitting there. Since my friend is looking to build a budget gaming pc I sold him the mobo and cpu and case.


Anyhow I found a really good deal on a FX 4100 CPU. Sure there not the best but it was so cheap and it will do for my bedroom PC. So I ordered it and since I all ready had a old AM3+ mobo spare that supports the 4100 I was good to go as soon as the CPU arrived.


My name cheap ass Cube case and CPU arrived so I used my old mobo/ssd/gpu/psu and put it all together. Pressed the power button all fans reved it. GPU fans started spinning. But noting coming up on screen. Just says no signal. So I tried another HDMI cable same thing no signal. I tried another HDMI port and again same problem.


Am thinking it might be my GPU as the HDMI cable when plugged in seems a little loose. But this happened when I had it with the intel and worked fine. I don't have any DVI cables or anything to try at the moment so am at a loss.


Any other suggestions I should try. I have taken it all apart again and rebuilt and it is still not working.



Thanks in advance.

have you got the right power cables from the PSU going to the GPU? 

Try it in a different slot. I had one that was bad on a previous board and I just needed to move it.

For full testing purposes, try it in a friend's computer and see if it works there. If it doesn't, you know its the card. If it does, you know its something else.

Yer the 7850 only requires a 1x 6 pin connector. My PSU has 2 of them. Do you think its worth trying the other 6 pin cable?

It never hurts, but if it is a cable issue, and they are serially linked, it may not display anything still. However, I would still try it.

Do you think its worth buying a dvi to hdmi adapter or a mini display port to hdmi adapter? As am thinking its the HDMI port.

Thanks for some of the suggestions. I have another 2 PC's I can take a GPU out of and try. But I rather tha be a last resort as there both awkward to get to at the moment. I will try another power cable and see if that works. I also found a molex to 6 pin cable so I will also try that.

That will check that one piece, but I would also recommend checking the cable as well. Use something that is being used elsewhere in the house.

This probably should have been the first question, but is everything plugged in and turned on? Also, make sure the display is set to the right input. I don't want this to seem like I am insulting or making fun of you, but I have done/seen it before.

Did you update the bios first before puting the FX cpu on the mobo?

I did yer I lent my friend borrow it a few weeks back. He was using a 8350 on it for a bit until his new mobo arrived.


Thanks for all the help. I got it working. I took the whole PC apart again. But I also took the battary out of the mobo for a minute. Put it all together and it works fine now.