New BT dongle not detecting new BT headphones

Hi all

I’ve been using a pretty old pair of Bluetooth headphones for so long that the micro usb port is basically completely worn out. I really need to fiddle and have the cable just right for it to charge.

I’ve also been using my old MSI dongle I got in 2006.

Decided I’m allowed some new stuff for a change. So I bought brand new Sennheiser HD 350BT and TP-Link UB500. Both say they are Bluetooth 5.0.

Problem is that the new dongle does not detect my new headphones or even the old headphones. Obviously… my old MSI dongle from 2006 detect the brand new headphones and works just fine :roll_eyes:

I know very little about Bluteeth… any advice??

AMD 5600x
Asus x570 Prime
Win10, fully updated.


As stupid test… I started my Linux Mint VM and the new dongle still does not detect anything. The old dongle with Linux Mint VM… works just fine…

Ok. The good news is that you have bluetooth working in general. That means there is a problem with the newer hw.

I’d start looking for the hw being recognized and drivers loaded.
I assume you attach both dongles via USB.
Try lsusb to see if they’re recognized.

Also, you can find a lot of information in the boot log.

  • start having both dongles removed from system
  • attach first (working) dongle
  • remove dongle
  • attach new dongle
  • run dmesg | less, hit “End” key or manually scroll to the end of the log.

You should see entries of both dongles being recognized and drivers loaded by the system. I assume that there may be an error message for the newer one.

1 Like

Sooo… I was a bit of an idiot… kinda. In short, TP-Link has a driver you can install and that fixed it.

I’m very used to plugging things in and it just working and not needing to get drivers from the manufacturers website… unless it’s something like a GPU. In my defense here, it was picked up and a driver was installed AND no issues was being reported. The dongle just did not detect anything…

Also, if we look at the info of the dongle on the site I bought it from…

Also, it works fine on Linux. Tested it with my laptop. Before it was not because I was running a Linux Virtual Machine on my Win10 machine.

So I guess it was/is a windows issue… kind of? Windows said it’s all fine and working, but I needed the driver from TP-Link to actually get it to detect any devices to pair with.

Feel a little dumb… I should have thought about what I would have done back in the WInXP or Win7 days.

Thanks for the info @jode, I’m not that well versed in the ways of the Linux so I did actually learn something :slight_smile:

1 Like

Well… that didn’t last long.

Yes, after the driver install, and a restart, I was able to pair using the new dongle and all seemed well. Over the weekend I wanted to watch a movie so I turned on the new headset and a voice played saying the following:
“Power on. Lost connection.”

Odd… I thought… turned it off and back on again with the same result and the new headset will not connect. Tried pairing again with no luck. Same problem.

Gave up and plugged the old dongle back in. Turned on the new headset again and it connected instantly and works with no issues.


I’m just going to stick using the old dongle. They just don’t make 'em like they used :wink:

I’ve done some more testing.

Although my Linux Mint laptop has built in BT, I used it to test the new dongle again and it seems to work just fine using Mint. I then tried the old dongle on the laptop and although Mint picks it up and I can search for devices, it does not detect anything.

So… I have a new dongle that does not work on Windows, but does work on Linux…
and I have an old dongle that does work on Windows, but does not work on Linux.

I’ll keep the new dongle as I will be switching to Linux on my desktop and then I’ll have at least 2 dongles and hopefully 1 of them will work.

I never expected this to be so much trouble, but it’s always the hardware you least suspect :wink: