New 5700 xt 50th AE low'ish fps?

so i bought one of the new radeon 5700 xt 50th anniversary edition graphics cards and its replacing my old radeon 4670 which is i think 11 years old. (imgur album) anyways with the same settings i’m not really getting much of a fps increase. is there anything other than graphics drivers that might effect this? i’m running an hp z220 tower with an i7-3770, 4x4gb patriot g2 1333mhz ram, and an intel dc3520 960gb ssd so cpu, ram, and ssd, all have plenty of headroom for the games i’m playing. its in a proper pcie 3.0 x16 slot. i am however using a hdmi to vga adapter. think that could have something to do with it? i do run linux xubuntu 18.04.2LTS 64 bit btw

Gpu fps differences

Terraria max settings not fullscreen
4670: min 55 max 60
5700: min 48 max 58 felt smoother though

Spintires: 1600x900 full screen proton 4.2-9
4670: 19fps min, max 32, 24/25 average
5700: 30 fps average graphical artifacts

Payday2: 800x600 full screen
4670: 60fps menu, 9minimum 34 max 24/25 average
5700: 206 menu, 22 min 89 max 50/70 avg

American Truck sim: 1600x900 full screen
4670: 45fps menu, 12fps min, 38 max 20/24 average
5700: 135 menu 28fps min 81 max

L4d2: 1600x900 full screen
4670: 270fps menu, 18 minimum, 93 max, 40/60avg
5700: 298 fps menu, 83 min, 142 max, 100’ish average

sacred 2 gold: 1600x900 full screen proton 4.2-9
i dont have any numbers but i do know i now have missing ui which are now large black area’s and i cast 1 spell and the game crashed.

i only ask because i have a c49rg90 on its way to my house and i’m a little worried that if that card cant power a 1600x900 monitor any better than my ancient 4670 how is it going to handle 5120x1440?

yes those aren’t the most popular games or the most demanding, however those are the games i play the most.

1 Like

no, but I have no idea why its running so bad

Unfortunately I am no help either other than to reinforce that it is definitely not right.

All but Spintires and maybe ATS should scream on that card (edit: even that is just a guess as I don’t own Spintires and as for ATS I run ETS with lots of extra map and that can cause slowdownd some times). I know Sacred has some of its own weirdness with newer OSs but if it was working before and the only change was GPU and its drivers than it should not be any different other than running faster on the newer card.

Could it be put down to new drivers an Linux? I know AMD are good with Linux but there seems to always be a period right after launch when things are messed up.

You probably want to be on the latest kernel so you have the latest amdgpu and mesa… which you may or may not like the idea of doing that.

i am using the drivers found on amd’s site with the 4.15.0-54-generic kernel. any idea how to force a kernel update on a lts distro?

edit: re-reading that site i realized i havent installed the vulkan sdk thing. i will install that when i get home and see if fps improves

well i installed the vulkan-sdk and on some titles like l4d2 i gained around 60fps to where i now average about 200fps with minimum being 100, but other games like american truck sim i lost 2fps… i’m so confused

You absolutely need the bleeding edge Mesa and the absolute latest kernel for the 5700 XT.

You can use the firmware files from the AMD drivers, but use Mesa and RADV instead of AMDVLK.

Use the Padoka Unstable PPA and install the latest kernel manually from the mainline kernel site.

1 Like

Im forced to update my GPU as well. I will be getting a 5700XT in the next few days.

Another thread listed the best support for now was using the binary AMD driver until ~sept when the kernel drivers in 5.3 are out.

I was going to test this out this weekend. If that helps or you get it working let me know :slight_smile:

The high variability in Framerate leads me to believe this could be a CPU bottleneck? If that’s the case, higher resolution should make this better.

Also, i’m not sure how many people Bench those cards on such low resolutions. Might be the case, that the card just isn’t great at low intensity, high FPS Games. Or some of the games engines just cap out at a certain point.

CPU would be my first guess though. And the 1333 RAM certainly isn’t helping either.

ok so my monitor showed up 2 days early and my fps doesnt seem to have been effected that much by the massive increase in resolution. on ats with the higher resolution i did finally hear my gpu spin up so i’m just going to wait for now for driver updates

Do you have similar experiences on windows with games?
Or is it just linux?

Because if you also experience similar frame variety’s under windows,
then i’m kinda leaning towards @domsch1988 's possible cpu bottleneck.
Especially when you say that with higher res your frame’s didn’t get affected,
but gpu is working harder.
This sounds to me that the cpu might be the bottleneck here.

no idea because i dont run windows, but like i said even with the massive resolution increase the fps didnt really change in the few games i tried that actually worked. l4d2 is interesting and annoying when trying to run it at 5120x1440

1 Like

Wait… What? Standard 1440p is 2560 wide, ultra wide is 3440, what is this madness? Two 1440p side by side?

Just gonna go look up the monitor you said earlier now.

Edit: Jesus jumped up christ that yuge.

new gpu and my monitor upgrade here are some links for you to see my gpu and monitor. yes the monitor is huge and is such a massive upgrade over my old monitor

1 Like

I got my new GPU. As with my luck changing it killed my MB nvme drive cause luck. I dont know it the NVME is dead or the MB port or something else. Even with the old card its not working. I do not have replacements to test it yet.

Thats aside Im tested it out on a windows 10 ltsb install I have and its kicking goals. I will most likely install linux on a spare sata drive. But quick tests on some default installs I have. As expected with the not yet complete linux support only my old dell LCD on a DP cable works with linux and the old TV on HDMI does not work at all on linux. So far.

Well after tooling around with OS’s I have. On hand.

Linux wise its been rubbish.The latest with POP OS and a payed for UKUU $12 licence has me at kernel 5.3rc3 and its unplayable gaming. Tried all 3 kernel 5 versions available and the stable kernel 5.2.7 is the same. Un-gameable on

On Windows I have Windows 10 LTSB and the AMD driver 19.7.4 that breifly worked was perfect !!! and you can not manually install again once newer software is installed worked well with old and new games running well that I play. Like supreme commander forged alliance and dragon Age Origins. Out side that window the games error as undetectable video card.

To top out window10 LTSB. Built in media player and installed VLC blue screen if you full screen video media so its windows sized only. Netflix and youtube content in chrome work fine full screen. I just have to remember normal video content will blue screen and wait on a crash save then the reboot time to windows which is fast due to SSD.

Im sure if I install pleb Spywear10 normie edition it may work.

I knew when my RX480 died it was going to be ruff. So it is. nothing I want works but many other games do and well there performance is awesome.

Ive benchmarked the card and its a great value for the price however. Im in the outlands for driver support. I want linux back asap. Only windows 10 ltsb will drive both my displays one is in portrait. Linux will only drive one and the main one if I power off the seconds portrait mode window. I cant even select portriat mode on that display and get it to work from kernel 5.0-5.3rc3 with fedora, ubuntu and pop_os.

Living the early adopter dream like my fond memories of the RX480.

so far even after upgrading my monitor my game performance stayed almost exactly the same, which confuses me, so i’m just going to stick with my current kernel/drivers until open source navi drivers are available and/or i get a lts kernel upgrade.

ok so last saturday xubuntu pushed an update that deleted my 5120x1440 resolution option. i manually added that back, but it wouldnt use it due to the new limit being 3840x1080. so i tried an uninstall/reinstall of the amdgpu drivers and to say my os didnt like that would be an understatement. it broke lightdm, .Xauthority, xserver and whatever else is used for the gui desktop. once i finally got that working somewhat it stuck me in a login loop that the general consensus on numerous forums was just to reinstall the os at that point.

so i spent all this week trying various os’s. i tried debian 10 which with the 4.19 kernel refused to load a desktop after install. without the desktop i gave up on this as i dont know how to select one of 2 partitions on a usb drive in terminal to copy the amd drivers from. then i tried manjaro and the installer just hated my gpu and it looked like a barcode on the screen so then i tried fedora 30 which did load a desktop but would crash every time i tried to open the display settings. it also refused to install the amdgpu drivers for rhel/cent 7.6. i had a few other hardware issues but they arent relavent to this thread. i might give fedora 31 a shot when it gets released with the 5.3 kernel but for now if you have navi avoid it.

not wanting to be stuck with 3840x1080, i paid the extra for a crg90 over a chg90 i want to use the max resolution) i decided i would just go to ubuntu which is the only os with official support (or was i think cent might have support now?). remembering that ubuntu now has a mate version i opted for this.

i had minor issues installing it (resolution acted weird and cropped off about 1/6th my screen) but got through that (thank god for tab + enter) and to the desktop which was stuck in 640x480 as my only option. installed the same amd drivers that xubuntu hated, i restarted and upon restart it defaulted to 5120x1440 @120hz which wasnt even available on xubuntu (it had 100hz as the highest). so i installed steam and waited for payday 2 to install and omg the difference is night and day.

i dont know what was going on with xubuntu, but it for sure gimped my fps. with payday 2 i now average 80fps in game and have seen a high 90fps as max and only one time in the 3 games i played did it drop down to 60fps (minimum) with menu running between 100 and 120fps.

i will report back on the other games once they download/install.


So Ubuntu Mate seems to have all the magic glue in place?
19.04 or 18.04?

1 Like

@Trooper_ish i’m running the 18.04.3lts. i value stability over new features. and yeah the magic glue is for sure better. i’d love to know what the difference between them is and why ubuntu-mate runs so much better than xubuntu.

also i jumped in american truck sim and its now up to a mid 50fps average (41min/121max) which is an increase of around 20fps for the average.

this is now running like i expected it would and cant wait to see what happens in the future when i upgrade from my i7-3770.

1 Like