Network config works on restart but fails on wake up

I’m trying to diagnose a network issue where some of my computers are configuring themselves correctly on start up but fail to configure correctly on wake up.

On start up they grab the default gateway of but on wake up they grab

I’ve tried changing the power settings to turn off fast boot up, and I’ve tried setting my routers to dhcp instead of static, I’ve also tried giving my computers static ip addresses, non of this has resolved to provide me with a stable internet connection and I’m running out of ideas.

If I set a static IP address on the client then revert it back to DHCP it configures itself correctly.

Any suggestions?

Sounds like your router and firewall are both trying to serve dhcp addresses.

Please provide detailed information about your router, firewall and hosts.

1 Like

So switches are
Default gateway:



DHCP Server

Other computers one the network are getting as the default gateway but this computer on startup gets and one wakeup gets As far as I can tell this computer is the only one with this issue.

You have 4 routers?

What OS and/or routing/firewall platform is running on all of these?

sorry 3 switches 1 router

Windows 10 client
HotBrick x2 firewall
Cisco Meriki router
Aruba iOn switches
Server 2012 r2 DHCP server

The DHCP server shows the address as having been leased out to the correct computer.

My first thought would possibly be multiple DHCP servers running on the same network. Have you verified the IP address of the DHCP server handing out the address using ipconfig /all?

1 Like

I have not but I definitly will tomorrow. I was sort of working under the assumption that it was the computer itself because all the other computers arn’t showing this flakey behaviour.

Im planning on swapping out the problem computer tomorrow and seeing if a new computer does the same thing and if it didn’t I was going to commit to the idea of it being an issue with the computer but I’ll rule out a second DHCP server first. If both those don’t show promise, then what else might it be?

Yeah, that was my thought also. Can you confirm that DHCP service is disabled on the firewall and router? Also, does the switch support DHCP guarding?

1 Like

Hmm, if you use a different (make/model) network adapter, does the issue persist?

This was perfect, it turns out that my firewall was intercepting DHCP requests and causing the issue, I’m just trying to get in touch with the previous IT person to figure out why this DHCP service is still enabled.

1 Like

If none of the DHCP Options or scopes are different other than the gateway, I’d just disable it. Glad to hear that was the issue though because I wouldn’t know what else would have caused that haha