Netapp SSD 520 -> 512 fail. Possible firmware issue? (Solved)

Recently picked up four 200GB Netapp SSDs for cheap. They’re recognized with SG3 utils but getting an “Illegal Request” error no matter what I’ve tried.

Controller: LSI SAS 9201-16i
OS: Ubuntu 20.04

Side note: OS is able to see drives and smartctl gives info about the drives.

Originally following this guide…

I have already read through and tried the suggestions in this thread…

using sg_format with size=520 gives the same exact error. Since the thread is from 2018, I’m starting my own.

The error I get is

format unit: Fixed format, current; Sense key: Illegal Request
Additional sense: Invalid field in cdb
Format command: Illegal request sense key, apart from Invalid opcode
FORMAT failed 

I suspect old firmware is the culprit. Currently the drives have rev N00 on them and everywhere I’ve seen success has N01. However Netapp doesn’t appear to have it available to just any street pleb. I had even tried signing up and it just gives me a 401 unauthorized message when I try to access the disk firmware link from their software page.

Any suggestions on where I can locate the firmware, if there are suggestions of what I could try to format these to 512B sectors, or anything else I would appreciate it.


Anyone have or know where I can get firmware?
The (what I assume is Samsung’s) part number is MZ6ER200HAFV-000G3.
The NetApp sticker has part number 108-00253+B3.
The IBM part number on the same sticker is 35P0004
I need the N01 firmware.

Ha! A solution was found. No firmware required. Screw you NetApp!

Using the setblocksize as instructed in the second link above worked! Mr. Allan Houston, if you’re out there, my hat is off to you.


This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.