Need Help with PlayOnLinux - MS Word will not launch

Recently installed MS Office 2007 on my laptop with Playonlinux. The install went fine and I can launch Excel and Outlook no problem. Word, however, only launched once (the first time) and since then will not launch anymore. I click 'run' and nothing happens. Sometimes it pops up with a wine dialogue box which then goes away (same thing with Excel and Outlook), but then nothing. I'm not sure what to do to figure out why it isn't working. Any help would be appreciated.

Running Ubuntu Gnome 17.04. Machine is an Acer E5-772G (i5-5200u with HD5500 + GTX 940m).

I would use Libre Office, but when I open a .docx file originally created using Word, the formatting is changed (font, spacing etc.) I'm working on writing a book that is currently 315 pages long and it's very important that the exact formatting be retained. If anyone knows how to get that to work properly, that would be cool too. :wink:

Can you go ahead and run Microsoft Word through wine through a terminal and then post the output so we can see what sort of errors are popping up when you launch it?

Will give that a try later today.

1 Like

Ok, apparently I don't know how to run it through wine through the terminal. I tried what I believed was the right command line, but it didn't work. I also tried searching how to do this but couldn't find it. I'm still a bit green when it comes to things like this.

Every time I try to run it in the terminal just goes to the ">" symbol and does nothing.

Actually you should try and run playonlinux on terminal. Not wine as the wine version that playonlinux runs is often a different one than the system version. Playonlinux choses the wine version per application and installs it separately.

1 Like

Thanks I will try that.

I'm trying to find instructions on how to do this, but not having much luck... How do I do this?

just run "playonlinux" in terminal...

Of course it would be that simple. >_< (and I thought you meant to run Word through Playonlinux through terminal).

Ok, it's up and running.

When I tried to start Word, this is the output:

[POL_Wine] Message: Running wine-1.6.2 start.exe /wait /unix $WINEPREFIX/drive_c/./users/mike/Start Menu/Programs/Microsoft Office/Microsoft Office Word 2007.lnk (Working directory : /home/mike/.PlayOnLinux/wineprefix/Office2007/dosdevices/c:/Program Files/Microsoft Office/Office12)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
[POL_Wine] Message: Wine return: 0

EDIT: Now Excel and Outlook won't launch either. They return the same message as above in the terminal.

i only Googled quickly, but here are two links to help with the spacing issue.

Thanks, I will check that out. It's not just the spacing though, it's many things (font type, size, etc.) that changes.

something within those two articles mentions that LO has to do an import/export dance every time it opens a docx file, so you might try backing up your manuscript and doing a Save As of the copy into whatever format LO uses for documents, then try modifying THAT one instead of the docx one.

I tried saving the document in Word (on another PC) as ODT format, then tried opening it in LO and the formatting was still changed. LO saves as ODF by default.

I work on this document on different machines, depending on where I am (at work, at home on gaming PC or laptop etc.) so if I can get Word to work properly in Linux, that would be the easiest and most ideal solution. I just don't know why MS Office[Word] won't launch anymore with Playonlinux after it worked the first time I tried it.

Will still check out that link you sent earlier and see if I can fix the spacing/formatting issues. If I can solve that, then I have no problem using LO. I save multiple copies of the manuscript after every time I work on it. So there's no risk if one version/copy gets messed up. There's always a backup. :wink:

I do not have Office to test this on, but after going to the link in your post, I've found this, so you should be able to apply this and voila, magic. :wink:

Thanks. I tried this but there is "no such file or directory". :frowning:

When I run "sudo apt-get update" I get the following message at the end:

Reading package lists... Done
W: GPG error: trusty InRelease: The following signatures were invalid: 74F7358425EEB6176094C884E0F72778C4676186
W: The repository ' trusty InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

@MEC_777 How did you originally install POL if you don't mind me asking?

Sudo apt-get install Playonlinux

@MEC_777 Did you happen to add any third party repos, or use the ones that can be enabled with the Software Center?

I followed the instructions on the POL website for the Ubuntu Trusty version.

They are as follows:

wget -q "" -O- | sudo apt-key add -
sudo wget -O /etc/apt/sources.list.d/playonlinux.list
sudo apt-get update
sudo apt-get install playonlinux

Anyone have any ideas?

I've still been searching in the mean time, but have had no luck finding a solution. :frowning: