Need help with GPU problem [Major read, sorry]

Thanks to anyone who reads this, I hope I can finally get this fixed. I'll start by listing my parts:

CPU- Intel i7 2600k 

Motherboard- MSI Z77A GD65 B3 Gaming  

RAM- Rip Jaws 4GBx2 1600

GPU- MSI 660TI Power Edition 2GB

PSU- Rosewill 750w

SSD- Samsung 830 120GB

HDD- Western Digital 2TB

Now for the problem, awhile back I noticed that my HDMI port on my GPU had bent pins, seeing how I only used HDMI this was a problem. Seeing how I also didn't have any other cables, I had to pull my GPU out to use my on board HDMI while I waited for my DVI cable. When it got here I put my GPU back in, plugged it in and screwed it down, connected the dvi from it to my monitor, booted, and this is where I am now. When it boots, it's stuck in a weird resolution like 640x400 and I can't change it. The bios doesn't display correctly, clipping pictures, only shows a 1/4 of the screen, but I can still use it. When it gets to the windoes boot screen, it displayed the green vista type loading bar(if Widnows 7 boots in a resolution under 800x600, the splash screen doesn't play, huh) then it goes to the desktop, still stuck in that resolution. It will say that my 660TI was detected and that drivers were installed. I reboot, and does all of the same stuff except after the loading bar, it's a black screen, not just black, like my moniter doesn't detect input. Same  goes if I wipe the drivers, reboot and install from the site. Does anyone have the slightest idea what I could do? 

Have you installed the proprietary Nvidia drivers, or just the default Windows graphical drivers?

Here's a better organized list of my build

  • CPU: Intel i7 2600K
  • Motherboard: MSI Z77A GD65 B3 Gaming
  • RAM: Ripjaws 4GBx2
  • GPU: MSI 660TI Power Edition 2GB
  • PSU: Rosewill 750w
  • SSD: Samsung 830 120GB
  • HDD: Western Digital 2TB

I've tried installing from both, let windows detect it, reboot, go on nvidia and download the lastest, install, reboot, let both happen. Nothing seemed to work

I've tried reinstalling the OS as well, with no luck. I hope my card isn't dying

Any other ideas? I'm drawing a major blank. I guess I'll just mess with it all night

Reseat the card?? this worked for me one time

Have you tried another dvi cable?