Need help[Solved]

So I keep trying to install Solus OS new project new comer to Linux grow together type thing ( take the Linux challenge) well the problem I keep running into is that no matter what I do even after following the Solus OS instructions I wind up with this

no grub bootloader nothing just a few lines of code and then this. Any ideas on what could be going on? Maybe a ID10T error who knows.

I should probably add it was the live usb install, and I have a modern system if that helps. I7 5820k x-99 motherboard 32 gigs of RAM with 980ti 500gb SSD and 2 terabyte mec hard drive. Bios is asus I disabled secure boot and also changed spare drives from MBR ( i think) to GTP as requested by the I should also mention I'm not trying to dual boot I want to abandon win 10 to do this.

1 Like

Is there a troubleshooting mode on the boot screen? do you know what kernel the LiveOS is using? I belive it is an issue with the Video driver and kernel 4.10.x...


Negative on trouble shooting mode on boot screen and it is kernal 4.8.2.

What is nomodeset?

Possibly redownload and resetup live USB.

1 Like

It's a kernel parameter. If you are booting to a black screen setting it can sometimes help.

Can you further explain I'm not sure if I follow.

There seems to be an issue with the GTX9xx series cards. Ikey has posted a workaround. I'll update this post if I can find the link.


Thank you @BarkingMad

I don't really think it's gonna help you since you since you usually would temporarily set the parameter in grub. Then if your system boots you would make it permanent by adding it to the grub config once the system is booted. However, since you can't get to grub I don't see how it will help you any.

These pages might help you understand better.

If anything I learn something new so thanks @crackthezer0

1 Like

OK, so the problem is that by default, Solus loads the open source nouveau driver for Nvidia GPUs. But there is some sort of nouveau/mutter/GTX9xx dilemma. In a nutshell, the workaround is to boot Solus with the "nomodeset" flag, and then install the Nvidia binary driver.

Here's a link to Ikey walking someone through the process.

EDIT: There is no need to make the nomodeset boot parameter permanent. Once the nouveau driver is replaced, the problem goes away.

When you highlight your Grub boot entry and press "e," the edit that you make (adding nomodeset) is temporary and it will automatically be discarded for the next boot.

EDIT2: FYI - To install the 64-bit Nvidia driver: $ sudo eopkg it nvidia-glx-driver
If you use Steam, you'll also need the 32-bit version of the driver: $ sudo eopkg it nvidia-glx-driver-32bit
Sometimes, you may not be offered the latest version of the Nvidia driver. You can install a specific drver version like so: $ sudo eopkg it nvidia-340-glx-driver-32bit

1 Like

I only had the issue with kernel 4.10.x on Fedora. 4.8.x worked well, so @HippyTree keep us posted

Yeah will do at work at the moment so when I get home will give it a shot.

1 Like

Ok so got home and gave it a shot again complete failure lol, not giving up hope :sunglasses:
So I took a couple of videos to show you what I was doing maybe something I did wrong?

Are you dead set on Solus OS?

Not exactly I had a criteria in mind I want to meet. And Solus just happend to meet all of them. The criteria I was looking for is
I wanted a minimalist os/ without a bunch of bloat
( I do not need 800 applications when I boot up I would like to have just bare minium applications and add what I wanted I learned more)
Lastly I wanted a distro from which I can learn from I am not interested in distro hopping that's what lead me to Solus to begin with.
I liked ikey' vision of making a Linux distro just work not just a re-themed packaging.
I had also considered arch as well, even though I know it would be a struggle to get going.