Need help on troubleshooting new PC build

Need some help. I have the exact build of the $350 Nov. Dec. 2012 video, 

What does it mean if I am not getting a display when the computer comes on? The hard drive and CPU is running. It just seems like I am not getting any display. Any quick thoughts or suggestions to troubleshoot. 


So i assume you are using the intergrated graphics. Do you have the latest drivers/BIOS installed?  Have you checked the BIOS to see it's set to use intergrated graphics?  Have you tried both the DVI and VGA connections?  Do you have a different Monitor you can try.

Yes I am using the integrated graphics. I am not sure about the latest drivers/BIOS. I am not sure how to check that. I did try the different DVI and VGA, still no display. I will try a different monitor. 


I tried different monitors still no display. 

Any more advice?

You may have a bad component, however before you start the RMA process, check that the display is set to the correct input. I had an issue with this earlier, and the crappy tv I had did not set itself. if you can't get any display to work, if you haven't seen your bios, I couldn't really help you, maybe someone else knows, but it does sound like it's a faulty output or some other component on your motherboard. Definitely get a second opinion from some others on the community.

Also, use different cables. Just to be sure.

The front panel is blinking red on the LED ... 

That could mean a few things, but the first that comes to mind for me is the hard drive. There are two lights on the front of a case (usually), the power light and the hard drive activity light. Check to see which is blinking red. I doubt the HDD light would be blinking at all if your PSU isn't functional though. try booting from another drive if you have one, or test the drive in another system if you can.

Edit: If you're having problems with your display not functioning though, this really does sound like a bad motherboard or processor.

I found the fix. It was a rookie mistake. There was one more power supply to plug on the motherboard

You probably missed the CPU power socket.

I've done that before in my early days xP

Yes that was exactly it.