Return to

Need help Enabling middle scroll button(auto-scrolling) [Arch] {lenovo ThinkPad E570}



Manjaro had it working out of the box for my T450s - when I can I will try to find the accoarding conf file.

Ok, I have not found anything particularely for the mous in X11 ... mhmm ... will have to google that


I tried installing Manjaro with KDE, but there was an issue with launching the live cd on the laptop.
I suspect that there is a video driver issue as the arch anywhere installation did not boot into a desktop environment to help with the installation


i did run linux mint back in day on my old thinkpad, it just never worked unfortunately :(


Anybody got the middle button to work? So far I am only getting the middle click on the trackpad to work.

Is there anyway to rebind the middle scroll to the Thinkpad dedicated button?


Did you follow the arc wiki for the xf86-input-libinput? ? That is how mine on the T450s works using Manjaro (wich is Arch based)


I tried that and it only does middle button on the trackpad, instead of the dedicated scroll button


Oh than lenovo changed that again.... what TP is it? Model?


Lenovo Thinkpad E570


Wait... do you want the scrolling just happening becaus you hold down the middle button? That's never how it worked... what happens if you hold down the middle button and move the nipple downwards? - that is how I have ever scrolled on thinkpads.


Nipple button + scroll button = cursor moving down, page does not scroll

Middle of the trackpad + press = page scrolls

What I want to happen
I want the first nipple button + scroll button = page scrolls




I am very sorry, but I can not find any information regarding your problem - it realy seems that it is still the same trackpoint/touchpad combination that is running in my T450s.
Have you actually given another distro a try - ubuntu maybe? - as to why Manjaro denies to work for you, that's odd - but out of the scope of the thread.

I realy tried to be helpfull, but google ain't giving me any information - I found a kernel bug that's fixed - maybe using 4.9.0-x kernel is worth a try (in case your not already using it)

The bet on my side would be trying to use another linux distro - or even windows to verify that the button actually works


The button worked in windows.
The only issue was configuring it for Arch.
I might make another thread for installing Manjaro.


You should check out their forum as well than: very helpful and very knowledgeable folks there - and me XD

Honestly, I am realy curious if it a linux-problem or a arch-something-deep-in-the-config problem


i found this

they said to but it was intended for ubuntu

Create a new file /usr/lib/X11/xorg.conf.d/20-thinkpad.conf with the following contents (on Ubuntu Maverick/10.10 and later, save the file to /usr/share/X11/xorg.conf.d/20-thinkpad.conf instead):

Section "InputClass"
Identifier "Trackpoint Wheel Emulation"
MatchProduct "TrackPoint"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
Option "EmulateWheel" "true"
Option "EmulateWheelButton" "2"
Option "Emulate3Buttons" "false"
Option "XAxisMapping" "6 7"
Option "YAxisMapping" "4 5"

on a different note i am having issues with booting manjaro on my desktop. The install is successful, but when I restart the computer it doesn't boot to manjaro


That's long deprecated.

Middle button support has long been added as core functionality since then.

All you have to do, is set the function you want for the middle button in the DE of your choice.


How do I do it gnome?
is it in the tweak tool?

or is it in the settings menu?

is there a program i need to install to bind keys?


Settings, Keyboard, there you will see the list of all "launchers", which is Gnome speak for keybindings. At the bottom of the list there is a "+", you can click that, select the function you want the middle mouse button to have, and click the middle mouse button as the trigger key. In gnome-tweak-tool, middle mouse paste should be disabled or the middle mouse will do both at once.


1 Year Linux Challenge

Wierd linux, gnome, or Arch had an update that makes the button work. I guess the laptop was new, so that’s what took a while?

Thanks @Zoltan @Th3Z0ne