My Threadripper build experience so far. Reseat your CPU

I just built a 1920x Threadripper computer. Asus zenith extreme, 32 gb ecc hynix ram (yes, I know…) 1050 zotac gpu (not a gamer), 256gb M.2 for boot, and an intel P3700 1.6 tb nvme drive I scored on ebay for cheap.

The 1920x was bought on ebay, however the first seller I bought from tried to scam me. Just sent me the box, and then tried to sell me the processor for $50 bucks more. Inside the box was a piece of paper printed to look like the 1920x. And he must have steamed the glue on the cardboard ring to get the processor out, as the security seal was intact. Ebay was great with the refund process. Immediately found another for the same low price, and the seller was awesome!

The Asus zenith extreme was also an ebay purchase, as untested parts only return. From the pics, the pins looked good, so I took the gamble. It was super cheap. $175ish Only missing some of the extras, like the dimm.2 card and the front panel q connector.

The ram was from Memstore on ebay. And I ordered before I knew that B-die samsung was the golden stuff. So I have hynix A die, and it is so far OK. Not much overclocking yet to report on. 2x 16gb, will get another 16 to take advantage of quad channel soonish. Just didn’t want all sorts of money in ram if the motherboard was a dud. These are real weird. 4 chips on one side and 5 on the other.

The night I was able to finally put it all together, I was unable to get the two sticks to finish post when any of the slots between the cpu socket and the rear IO were populated. So in the interest of getting my new toy up and running, I populated two slots on the one side that worked.

Dread filled my mind. Was my motherboard broken? Would the memory slots between the cpu and rear IO ever work? I lived with my machine as it was for a week, as a half working machine is better than a not working machine. Plus, it was so fast and awesome, even if 4 cores didn’t have direct memory access.

Tonight I bit the bullet and took the heatsink off and reseated the CPU. As I tipped up the carrier tray slide, I saw a single hair in the socket between the pins and pads. (I am a hairy guy). I don’t know if the hair was the problem or not, but I know it wasn’t helping. After hair removal, and a reseating of the CPU, All the memory slots on both sides of the CPU work!

Just thought I would share. Reseat the CPU, it may solve some problems!


Alternative is to shave off all body hair before building


That takes so long that the areas shaved in the start are grown back. Kind of like painting the Golden Gate Bridge is never finished.

I guess I have to get one of those clean room suits.


And after a reboot, I had to reseat the ram nearest the rear IO. And finally moved the stick from C1 to C2 (the very nearest slot to the CPU). Which according to the manual is not ideal. ARGGGGG

However, I am now at 2866 mhz stable (ish, not enough time to test fully). And previously 2800mhz would crash occasionally. Hoping for 2933!

Well thats progress-ish… as far as the hair causing an issue, probably not unless of course you have metallic glitter in your hair at which points all bets are off.

1 Like

For all of the tales from tech I’ve heard

I’ve never heard of a hair breaker

1 Like

Wish you would have taken a picture for the Tech Cringe Thread.

Eitherway, I had an issue the first time that I seated my 1920x and it wouldn’t play nice with the ram and wouldn’t post. Took out a few sticks and reseated the processor and it worked. repopulated the ram and it stopped working. Then it turned out that 1 of 4 of my sticks was bad. RMA’d the set, got a new set and it’s been working fine ever since. These threadripper processors are definitely finicky when it comes to seating them and tightening them down in those massive sockets.

Reseating everything a few times and using the process of elimination while troubleshooting these machines it definitely good advice. Thanks for sharing.

1 Like

Well, the newest Bios for the Zenith Extreme came out recently. This morning I applied it, and it seems to have solved the ram issues. On the previous bios ((version 1601) any time I fiddled with the ram timings, there was a 50/50 chance one of the ram slots between the cpu and rear IO would drop out. Even if going to looser settings, or from settings that previously had worked without problem. Sometimes it would even stop the system from completing post. Sometimes just going into the bios screen and making no changes would be enough for it to fail to post on the next start up. Eventually I got to the point that instead of shutting down, I just put the system into suspend, since once I was fully booted it didn’t seem to lose ram or be unstable.

With the newest bios, version 1701, the board is rock solid. I spent the afternoon fiddling with ram settings and not a single time did it lose a stick of ram randomly or fail to post, unless the settings were way too tight. I have shut down the system a bunch of times, and even verified that some ram settings are too tight, and every time, it at least got to the bios, instead of hanging on post and requiring reseating of the ram.

I will test over the next few days, but the system is now performing just as I had hoped (or at least as well as I can expect from bargin bin used parts). The major issue fixed for me in the last bios update is making the system more reliable, or at least not randomly hang on post, even when nothing changes.

Was the bios + hynix a die ram the issue the whole time? Maybe. Probably. Would Samsung B die have solved the problem, probably yes. Will I be getting some B die? eventually I bet. But right now with my hynix a die and the new bios, it is running well enough. And it is to the point I will start fiddling with the ram settings and eeking out the last bits of performance from my system, without random hangs and non posting confounding the situation.

Well, a weird ram thing was found out today. In some other thread Wendel posted that overclocks can make TR1 ram slots unstable. Or something to that effect.

I have two sticks of 16gb ecc hynix ram. In A1 and D1 I am rock stable at 2733, with a bunch of the timings really tight. Not a great overclock, but I will take what I can get. The ram ended up in those slots since before the last Bios update, which made things more stable.

At the current over clock, no slot near the IO shield is stable at 2733 except D1. I found this out today by testing and trial and error. Before the Bios update, I only ever got even bone stock setting stable on D1. I feared there was a problem with the slots on that side, as I got the Mobo as a very cheap return sale. It did not bother me that much since I only had 2 sticks, and honestly the threadripper is overkill.

In testing today, I found that the other slots are able to be stable, just at lower speeds. Which is nice, since it means I can maybe get more ram for more overkill, and have them work, even if at lower speeds.

I only tested slots C1, C2, D1, and D2. I will be testing A2, B1, and B2 to see if I can get a little more out of my system. I have had 2800mhz booting and running, it just wasn’t Memtest86 stable.