Return to Level1Techs.com

Multiple Drivers Fail to Load with Memory Errors

This is a problem that has HPE and Canonical stumped. The problem began with the i40e driver failing to load properly, preventing multiple Intel X710 Ethernet adapters to fail. The driver would try to load, wouldn’t find the device, and fail. You can see the PCI device but can’t use it. We eventually switched those out for Mellanox devices which work without error.

But the problem is back and this time with Nvidia A100s. Errors are not exactly the same but all reference PCI memory space. Same problem, completely different devices would seem to point in the direction of the server chassis but for the annoying fact that the problem presents in both Ubuntu 18.04 and 20.04 but no problem exists in RHEL 7 or 8. It all works in RHEL. For reasons not in my control there is a strong desire to land on Ubuntu 20.04. We have two of these servers and both are brand new to our environment.

Solutions would be awesome, if anybody has seen this before, but some good ideas would be equally appreciated. Canonical at one point suggested basically the same steps as configuring VFIO PCI Passthrough and I thought it was crazy enough to work, but it didn’t. Given deadlines and availability issues swapping out this hardware for something else isn’t very doable.

Error sample:

Mar 31 10:04:32 hostname-redacted kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 510
Mar 31 10:04:32 hostname-redacted kernel: NVRM: request_mem_region failed for 0M @ 0x0. This can
                              NVRM: occur when a driver such as rivatv is loaded and claims
                              NVRM: ownership of the device's registers.
Mar 31 10:04:32 hostname-redacted kernel: nvidia: probe of 0000:88:00.0 failed with error -1
Mar 31 10:04:32 hostname-redacted kernel: NVRM: request_mem_region failed for 0M @ 0x0. This can
                              NVRM: occur when a driver such as rivatv is loaded and claims
                              NVRM: ownership of the device's registers.
Mar 31 10:04:32 hostname-redacted kernel: nvidia: probe of 0000:89:00.0 failed with error -1
Mar 31 10:04:32 hostname-redacted kernel: NVRM: request_mem_region failed for 0M @ 0x0. This can
                              NVRM: occur when a driver such as rivatv is loaded and claims
                              NVRM: ownership of the device's registers.
Mar 31 10:04:32 hostname-redacted kernel: nvidia: probe of 0000:b1:00.0 failed with error -1
Mar 31 10:04:32 hostname-redacted kernel: NVRM: request_mem_region failed for 0M @ 0x0. This can
                              NVRM: occur when a driver such as rivatv is loaded and claims
                              NVRM: ownership of the device's registers.
Mar 31 10:04:32 hostname-redacted kernel: nvidia: probe of 0000:b2:00.0 failed with error -1
Mar 31 10:04:32 hostname-redacted kernel: NVRM: The NVIDIA probe routine failed for 4 device(s).
Mar 31 10:04:32 hostname-redacted kernel: NVRM: None of the NVIDIA devices were initialized.
Mar 31 10:04:32 hostname-redacted kernel: nvidia-nvlink: Unregistered the Nvlink Core, major device number 510 

Server info:

ProLiant XL270d Gen10

Architecture:                    x86_64
CPU op-mode(s):                  32-bit, 64-bit
Byte Order:                      Little Endian
Address sizes:                   46 bits physical, 48 bits virtual
CPU(s):                          112
On-line CPU(s) list:             0-111
Thread(s) per core:              2
Core(s) per socket:              28
Socket(s):                       2
NUMA node(s):                    2
Vendor ID:                       GenuineIntel
CPU family:                      6
Model:                           85
Model name:                      Intel(R) Xeon(R) Platinum 8280 CPU @ 2.70GHz
Stepping:                        7
CPU MHz:                         1000.037
CPU max MHz:                     4000.0000
CPU min MHz:                     1000.0000
BogoMIPS:                        5400.00
Virtualization:                  VT-x
L1d cache:                       1.8 MiB
L1i cache:                       1.8 MiB
L2 cache:                        56 MiB
L3 cache:                        77 MiB
NUMA node0 CPU(s):               0-27,56-83
NUMA node1 CPU(s):               28-55,84-111
Vulnerability Itlb multihit:     KVM: Vulnerable
Vulnerability L1tf:              Not affected
Vulnerability Mds:               Not affected
Vulnerability Meltdown:          Not affected
Vulnerability Spec store bypass: Mitigation; Speculative Store Bypass disabled via prctl and seccomp
Vulnerability Spectre v1:        Mitigation; usercopy/swapgs barriers and __user pointer sanitization
Vulnerability Spectre v2:        Mitigation; Enhanced IBRS, IBPB conditional, RSB filling
Vulnerability Srbds:             Not affected
Vulnerability Tsx async abort:   Mitigation; TSX disabled
Flags:                           fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdt
                                 scp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx
                                  est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dn
                                 owprefetch cpuid_fault epb cat_l3 cdp_l3 invpcid_single intel_ppin ssbd mba ibrs ibpb stibp ibrs_enhanced tpr_shadow vnmi flexpriority ept vpi
                                 d ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid cqm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb intel_pt avx512cd
                                  avx512bw avx512vl xsaveopt xsavec xgetbv1 xsaves cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts hwp hwp_act_window
                                  hwp_pkg_req pku ospke avx512_vnni md_clear flush_l1d arch_capabilities

88:00.0 3D controller [0302]: NVIDIA Corporation GA100 [A100 PCIe 40GB] [10de:20f1] (rev a1)
89:00.0 3D controller [0302]: NVIDIA Corporation GA100 [A100 PCIe 40GB] [10de:20f1] (rev a1)
b1:00.0 3D controller [0302]: NVIDIA Corporation GA100 [A100 PCIe 40GB] [10de:20f1] (rev a1)
b2:00.0 3D controller [0302]: NVIDIA Corporation GA100 [A100 PCIe 40GB] [10de:20f1] (rev a1)

HPE finally put their finger on the solution. This is a new one to me so I’m please to share.

The root of the problem is PCI re-allocation. It is set to OFF by default on RHEL/CentOS but is ON by default on Ubuntu.

The fix:
In Grub, add “pci=realloc=off” to GRUB_CMDLINE_LINUX_DEFAULT.
Source: https://support.hpe.com/hpesc/public/docDisplay?docLocale=en_US&docId=a00112218en_us

Thanks for taking a look and I hope this helps somebody else.

1 Like