Return to Level1Techs.com

MSI TRX40 Creator NVME.2_3 drops network issue

I have a strange issue with my computer. When I plug in an NVME drive into the NVME.2_3 connector I loose my internet connection. I’ve tried two different NVME drives and get the same result. Removing the drive returns the network connections to normal.

I’m running Proxmox 6.1. I believe this is a linux setup issue but am not sure how to troubleshoot/fix the issue.
When booted with the NVME drive in place, I can ping my host address and the return result is good. The output of ‘ip add’ shows the correct static address (of course because it’s manually set). But when I ping any LAN or WAN addresses I get 100% loss.

The output of lspci -v shows the two NIC’s I have are available.

Any pointers would be much appreciated!
Thanks
Andrew

most linux network device names are based on the pci location…

so the network device name is likely changing when you have the nvme installed.

1 Like

Thanks for the quick help! That indeed was the issue.

1 Like