MSI GT73VR: GPU passthrough

Would like to know if I can get it working on this laptop.
Host: linux
Guest: Windows 10

More info would be required like -
Does your discrete video card ( NVIDIA ) has direct output ( I/O ports like HDMI or Display Port or VGA or whatever your laptop has ) or do they go through the integrated graphics ( Intel ) ?
Do you have external monitor ?
Does your motherboard and processor support VT-d ?

  • The laptop has two graphic cards, one is the integrated of the 6700HQ and the other is the nvidia gtx 1080. You can choose which one to have “activated” from UEFI BIOS or pressing a physical button on the side of the computer and then rebooting:
  • On Windows 10 the physical button works right away and prompts to reboot, however on linux additional software is required:
  • Yes it supports VT-x and VT-d

  • On the back of the computer there are 1x HDMI and 1x Mini-Displayport. I guess the selected card is the one outputting sound& video.

  • The laptop has built-in display [email protected] but I have a TV also so could be connected over HDMI. If I could the same screen for host and guest would be great because the TV is only 60Hz while the built-in screen is better for gaming.

  • Wonder if external monitors like Asus MB196B+ or Asus MB196C+ could work.

  • MSI GT73VR 6RF Titan Pro Specification:

  • Additional links:

Kernel mode setting

PCI passthrough via OVMF

There are news. Finally followed the @GrayBoltWolf guide:

And everything worked as expected, to the point of adding “vfio-pci.ids=10de:13c0,10de:0fbb” and “pcie_acs_override=downstream” to “/etc/default/grub” obviously using my own ids. The problem is that after rebooting linux, it doesn’t boot totally anymore. Just shows the following error message:

[0.174037] ACPI Error: [^^^PEG0.PEGP.EASP] Namespace lookup failure, AE_NOT_FOUND (20160831/psargs-359)
[0.174044] ACPI Error: Method parse/execution failed [\SB.PCI0.LPCB.EC._REG] (Node ffff970cee0e8668), AE_NOT_FOUND (20160831/psparse-543)
/dev/sda2: clean, 438811/14557184 files, 8646422/58203271 blocks

If I edit kernel line with “e” before booting and remove the two latest parameters for vfio it just boots ok again. Could it be that IOMMU is not supported by my UEFI BIOS or motherboard?

In case it was related to, I tried with both drivers for the Nvidia card, the proprietary from Nvidia itself with the .run installer, and the default nouveau driver.

Regardless of the driver being used the problem still persists, so probably the freezing issue at kernel boot is not related to the driver for the graphics card.

Another issue faced with the nouveau driver just after installing devian and prior to any modification, was the following boot error which prevented the system from booting:

[40.743528] nouveau 0000:01:00.0: bus: MMIO read of 00000000: FAULT at 00e304 [ IBUS ]

The error was fixed adding nouveau.modeset=0 to the kernel parameters and running update- grub as root:

[Solved] Nouveau error spam on boot