Msi GS70 2QE Red Edition Intel RST Linux GPT corruption/errors?

I’ve had this this laptop (Msi GS70 2QE Red Edition) for 7 years now. It’s been getting on in age bit a 4th gen i7-4710hq and a gtx 970m but still runs fairly well minus a wifi adapter that I think disconnects itself and sometimes reconnects.

With the advent of windows 11 needing a tmp 2.0 chip, I figured it was time to try and install linux on my raid volume and use the laptop as an kind of linux experimental to extend its life and prevent ewaste. I’ve been doing a bit of a messy dual boot at the moment through loading MX_Linux, having to change the boot order due to weird stuff about Raid I was’t comfortable with messing with at the time and distros seemed to not detect my Raid Array. So I’m kind of familar with some linux stuff, but still beginner to intermadiate.

While later down the line (like this year) I noticed some Live usbs did start to detect that volume. “Sweet!” I thought “maybe an install can detect it?” Sure enough the latest Mx_Linux 21 and POP!_OS 20.10 installers could pick it up array and read all the paritions (volumes?). I was all set to see if I could dual boot the drive because I still had a year and I wanted to make sure that there was absolutely nothing left behind until the end of extended support on 2023.

Of course being cautious, I backed up my files, made two different system images, a few restore points and even a recovery usb just in case I messed up. I was all set to try it out, and install POP!_OS when the official 20.10 release came out and give it a try since the Live environment Seemed to work outstandingly well with the hardware.

but I couldn’t leave well enough alone…

I started to wonder… “Okay that’s cool, but why can’t my Mx install read my array? I have a bit before 20.10, lets see if I can figure this out” I had Mdadm installed, thinking that it could read any raid array but it’s only software raid. Then I found out that dmraid, while an abandoned project, does support Intel raid software and sure enough both live usbs had then installed.

So I installed dmraid on the mxlinux 19 install and the Volume Showed up. HAZZAH! After checking I could access it I rebooted and… it was gone again. Uh oh. And an error on a tray Icon read “/proc/mdstat exists but doesn’t contain any raid.”

Trying to troubleshoot the problem Gparted gave me a few different errors:

• Invalid argument during seek for read on /dev/sda/

• not all space available to dev/sda(b)(d)/ you can fix the GPT to use all of the space (512 blocks) (I don’t remember the exact blocks sorry) or continue with the current setting? [fix] [ignore]
(I do nothave my own image because I hit fixed I will provide a image of a similar situation)

• the backup gpt table corrupt but the primary appears to be okay, so that will be used

Mx Gpartedargument
Mdstats (2)
GPT corrupt

(Image is from this gitlab post: Errors with GPT on RAID 0 ATARAID array (#75) · Issues · GNOME / gparted · GitLab which was similar to what I saw)

So I think I made several mistakes.

First one is trying to use the Intel rst since it’s not well supported on linux but… I wanted to see if I could get away with it, and didn’t want to start from scratch if I messed up and have to rebuild everything. Also it seems I my need to update the RST driver (It’s like version 12.XX.X ect.) on the laptop as achi mode doesn’t even detect the window boot in bios setting if I switched to ACHI mood atm. So, couldn’t easily switch the controllers like how the guides would tell me to do.

Second I probably should have just upgraded MX Linux to 21. Probably would have been easier since the driver was already installed on the live usb. Probably was the safer method, but I figured if I going to delete mx in favor of POP!OS I thought I could experiment and see if I couldn’t just install the correct driver, and get it to appear myself, and at least get familiar in the meantime.

third Hitting that damn Fix button on the GPT error that over writes the array metadata. Apparently that make the metadata, but I can still boot into windows 8.1 so I’m not sure what that’s about if you’re in my situation hit IGNORE. Other wise I’ve found that the live installers now will detect the raid volume but think it’s unallocated data (but the MX linux install can still see the volumes in gparted but can’t read them and says the volumes do not exist)

(How it looks on current MX Install in gparted with how the partitions should look)

(How it looks like in the installers for either distro):

Screenshot from 2021-10-27 12-23-47


(gparted as well)

So I guess what I’m asking is if there is away to fix this now that I have messed this up this badly. Like if there is a way for me to reconstruct, or manually write the metadata if I can figure out what it was before I messed with the GPT?

Is there a Reason why installing Dmraid could have worked once, then stopped working after that reboot?

If not, I want to better understand where I want wrong, why this all broke and hope that this could help people in my situation in the future. I just have to swallow my pride and admit I don’t know what I’m doing when it comes to RAID, firmware or software.

At this point I’ve accepted that I may need to either delete the raid volume and start with a fresh volume from scratch (either with fake raid or Linux software if the overheads not too bad), and if that fails just install pop!_os on a disk by itself when the extended support is up. Though, if I was to do that, would I still be able to enter in the uefi/bios I did delete the volume with boot partition? (I need to make sure) And if I was was to remove a disk from a RAID0 from the array, could that be done without losing the OS?

TL;DR: planned on installing POP!_OS. In preparation I installed Dmraid on Mx linux which had my raid volume show up until I rebooted, might have broke the GPT table in the process of troubleshooting. Not sure if there’s a way to fix this without starting over, and I am hesitant of wiping the drive even with all my back ups if something went wrong.

Sorry that this was long, but I needed to go through the whole story because I know it’s an atypical set up, and I wanted to ahow there’s a sort of method to the madness and how I got to this point. If I need to provide screenshots for visual clarity I will to the best of my ability, but my main concern was to get words on to screen atm.

[Edit: Added pictures and formatting for better clarity and so it wasn’t just a wall of text]

Update: I installed the latest version of Intel RST (software) and Verified the drives through windows with the Software and the Array is showing up correctly in both now on the Live usb I’ve tested with. Still not sure why any of this has happened but I’m not complaining. I won’t with my current Mx Linux install I don’t want to worry about breaking this again. I’ll probably make another update/post when Pop_OS 21.10 releases and document my progress with that.

Current POP_OS example: