Mouse stutter in 3D games

Issue: When I play a 3D environment games like the Witcher 3, ASSCREED Origins or Odyssey, or Borderlands 2 my frames seem to stutter or move choppy when i use the mouse to pan the camera left right or up down. This does not occur when I use a gaming controller.

System Config: Asus Prime Z390-A, Intel 8700k, 32GiG of 3200Mhz DDR4 Trident-Z RGB RAM. M.2 NVME boot drive, 1 Platter data drive, GTX 1070. All are generally overclocked and watercooled.
Corsair Scimitar Pro and K70 RGB running with ICUE

Troubleshooting done: Re-installed game on different drive, switched mouse to different USB port, tried a different mouse, re-imaged windows, rolled back all my overclocks to default, uninstalled and re-installed mouse drivers, swapped out the video card, unplugged mouse and keyboard and ran them from my steam link (yes i have one). To this point I would think the issue lies the cpu but im not sure.

Does anyone have any suggestions. I have pulled out what little hair I have left.


V-sync issue maybe? or something related to frame rate managment like freesync/gsync.

Oh some games also have a special handling for mouse input. Try disabling/enabling that too.

I’ve toggled vsync on and off with no change. Sadly I don’t have a freesync/gsync monitor just a boring normal 16:9 Asus one. I’ve also toggled mouse acceleration on and off as well as hardware cursor. I would love for this to be an issue with just 1 game but it sames to be for anything that isn’t isometric like an RTS.

I do appreciate the followup

Have you tried to toggle between fullscreen mode and windowed mode? What about your UI scaling on Windows? Is it set to 100% or something above? I seriously doubt this is due to CPU issue since it doesn’t happen with controller.

What probably happens is your cursor is not locking by the game process properly. Its probably locking and unlocking every second causing the game to switch between background mode(usually set to low fps to not waste gpu ressources) and focus mode.

My experience with stutter like that is usually a CPU bottleneck, but in your case I can’t imagine what would cause it.

Try closing any software for your mouse and keyboard.

this is the best possible explanation i have read so far.
I’ll continue to use witcher 3 as my frame of reference since that is where the issue appears more upfront. There is some stutter in Blands2 but not on the same scale.

So I have toggled between fullscreen and borderless windows, I have changed v-sync on and off, set framerate caps to 60, 75, and off. i have toggled hardware mouse on and off. I have set the graphics all the way to low, re-imaged the pc, re-installed the game, launched the game outside of GoG Galaxy.

Outside the game, I have changed primary boot drives because i read that sometimes there can be issues with peripheral throughput on nvme’s. I replaced my video card(not because of the issue though, i just really wanted a 2070s).

I also built a system for my friend that i had the same issue on, and that is completely different system. his is an AMD build with MSI parts where mine is intel with Asus and Gigabyte. The only similarities between the 2 is that they are using nvidia based gpu’s. his is a 1660ti and mine is a 2070s. The boot drives are the same make and model, and the 3rd similarity is me. So unless my eyes are going or I have a f’d up wrist, i can’t make heads or tails of this.

Is there a setting or a way i can test if the cursor isnt’t locking?

Thanks much

At first I thought it was ICUE. when I re-imaged i purposely didn’t install geforce experience or Icue. Just the video driver, and GoG, steam, and tested the same games. still persistent. At this point i wish it was the mouse.


This might be able to help you to figure out what happens during the stutter. I haven’t used it for a long time as I am not on Windows anymore. I believe this program had a way to see what events happen for each process.

1 Like

Thanks man/mam
I’ll give it test. I’ll also be sure to take a vid of games using mouse vs controller to have a visual rep


Some paint testing with mouse, outside of the fact that I can’t draw worth a damn with a mouse, i think these look fairly normal

You need to test with Opengl/directx programs. I don’t think paint uses graphical accelerators.