Mouse randomly slows down in Ubuntu

Hello,

I have a weird mouse issue that is driving me nuts.
The mouse keeps randomly slowing down, it feels like the DPI drops by half for like 5-10 seconds and then it’s back to normal. It happens pretty often.
I even tried to eyeball it by checking how long it takes to go from left edge of screen to right and the mouse distance traveled from edge of mouse pad. I definitely need to slide it further when it feels slow hence it feels like DPI dropped randomly.

I’m using Ubuntu 20.04 LTS, x299 mobo with 10980xe, L1 KVM and a Logitech gaming mouse.
I tried 3 different mouses (redragon, razer, logitech), swapped the usb cable, tried different usb ports and it’s still the same. I tried checking logs just after the slowdown happens but nothing seems out of the ordinary.
It only happens on Ubuntu while windows is fine.

Mouse acceleration is set to flat (off) using tweaks.

If I remember right, I didn’t have this issue when I first installed 20.04 and it might have been an update that did something. However a recent install of 20.04.3 iso has this issue from the start.
So to test this I would need to format the computer using an old iso like 20.04.1 and don’t install any updates but I would like to avoid that.

Does anyone have any ideas what could be the issue? Or any settings/logs to check? USB power saving? Different mouse acceleration setting?

Thanks

Do you have the “sniper” button configured (the one that decreases DPI when held)? Are you certain you are not triggering it with a misclick? Maybe temporarily change the binding of the “sniper” button to something else?

1 Like

hmm, can you load up the mouse software on windows?.
open the config and disable acceleration there.
save the profile to the mouse if it has the option. then jump back into linux and hopefully its fixed.
?
it sounds like your linux is disabling acceleration in software but the mouse is saying acceleration is on.
end result the polling rate climbs and falls on as the mouse and o.s argue and compensate.

2 Likes

@regulareel Nope, no sniper button, I have the Logitech G600 MMO mouse now. The only DPI buttons are on the top next to mouse wheel which are hard to misclick. There is a button thats easy to misclick on right side like a finger rest but that’s configured to “back” button.

@HEXiT Yup I can load the software and that’s a good idea! I didn’t think of mouse having its own acceleration setting in software. I will look for that and try disabling it.

Two things…you used to have to edit /usr/share/X11/xorg.conf.d/50-mouse-acceleration.conf in Ubuntu to disable mouse acceleration. Obviously if you’re using Wayland this is useless and god help you…The acceleration can be inconsistent on some mice due to what I can only call as stupidity. Check in your normal mouse options if your device shows up more than once (different names but still same device)…you will notice each listing has it’s own settings/acceleration…let’s just say if this is the case Ubuntu likes to randomly choose which one to use mid movement/action…

Atm my mouse shows up as 3 separate devices. “mouse name”, “mouse name” consumer control, gaminggearuhidmouse! (Not in Ubuntu btw) The cheesiest/easiest thing is either disable in the conf or make sure (if you have more than one listing in your mouse settings) the system accel is disabled for at all but one listing.

1 Like

So I checked the mouse software and there was no mouse acceleration option for on-board mouse profiles.
I found however a “G Shift” setting which is like the sniper button, but it wasnt set to anything after all.
So I tried one more thing while in the software, I deleted ALL DPI levels except one main one on all onboard mouse profiles.

That also didnt fix it, still random slow downs even with only one DPI level.

@get_off_my_lawn
Hm, I don’t think xorg.conf.d/50-mouse-acceleration.conf is used anymore.
I found this on reddit:
“In the past, Xorg used an input driver named “evdev”. Today the one used by default is “libinput”. The two drivers use different options which I guess is why your file doesn’t work anymore.” by user ropid

I think the one in tweaks extension should be the current used setting replacing the xorg setting which is already disabled.

As for showing multiple devices, I think mine is just one device? I checked lsusb.
And “xinput list” shows a different brand mouse(?) along logitech. I think that might be related to keyboard USB hub? Since same brand as keyboard.

However doing list props shows as the acceleration disabled for both:

xinput list-props 'Logitech Gaming Mouse G600' | grep Accel
    libinput Accel Speed (298):	-0.250000
	libinput Accel Speed Default (299):	0.000000
	libinput Accel Profiles Available (300):	1, 1
	libinput Accel Profile Enabled (301):	0, 1
	libinput Accel Profile Enabled Default (302):	1, 0

0, 1 value should mean disabled under libinput Accel Profile Enabled

As I said, USED to be set in the .conf ;p You never said if you checked for the duplicates in the normal mouse panel. That said I also don’t know what DE you are in that may or may not be the issue. Given you said Ubuntu the assumption would be gnome for which you may need Gnome Tweaks to get to the bottom of the stupidity.

As a side note why aren’t you running libgaminggear or ratbag for the mouse so it can be used correctly?

1 Like

Ah, I looked at the normal mouse panel but it did not show anything like source selection. Options here are certainly lacking.
Yup, it’s gnome and I also have gnome tweaks already installed, but also not seeing anything like sources there either.
Here is a screenshot of both:


The acceleration is already disabled/flat. Other tabs don’t really have any mouse settings.

I was not familiar with those two apps but I now installed ratbag+piper gui.
The onboard mouse profiles got detected right away and showed the settings I set on windows.
However right as I was going to reply, the mouse slowed again =( so it doesn’t seem like it helped with slowdowns.
It’s super useful for editing the key settings, but I usually set those once and then never change them again so I never looked into those apps and the onboard profiles did the job.
Still I will definitely save the ratbag app, it will come in handy when I don’t have a windows machine to change the key settings. Thanks!

Try disabling desktop composition if possible. It sounds like some timing issues might be dropping your desktop framerate, which will have the effect of slowing the mouse movement down as well in many cases.
nVidia drivers can also hang mouse input, so if you get IO nvidia hangs every other update, the mouse will be moving at half speed.

2 Likes

I think @alkafrazin may be on to something. While it’s not hangs that are the issue (my nv driver kinda hangs my whole system too frequently when I have heavy separate 3D workloads across my GPU’s) Gnome is a pig and its compositor may be to blame. There was an application to show fps even on desktop use. This might be useful to see if it’s a dpi/input issue or dropped frames. Or you could try a less piggish DE like XFCE.

Another thing is also what ARE you running? X or Wayland? There is a chance given Gnome and mainline Ubuntu that you’re in Wayland which would be a potential issue. If you are in Wayland switch to an X session and see if the issue goes away. (Cue rant about wishing Wayland and Pipewire would die in a fire.)

At the very least always have a term open running dmesg -Hw or tail -f /var/log/syslog and see if something is happening when you notice the input drop. A multitail following both would make is easier to see if your video drivers have issues. (You also never said what video drivers you’re using or if you’ve tried without the KVM ;p)

desktop composition like visual effects?
i saw option to disable animations in tweaks but dont see anything in official settings or anything clearly related to compositor.

i found a post from 2 years ago that mentioned:

"You can’t disable composition on GNOME. It’s always enabled.

For games GNOME should automatically undirect fullscreen windows (suspend composition). KDE developers prefer to disable whole compositor instead." by nightblackdragon on reddit

So I don’t think I can disable it?

nvidia driver hang is an interesting thought indeed, how would the hangs look like in the logs?
I’m seeing stuff like this

nvidia-settings[40021]: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
nvidia-settings.desktop[40021]: ERROR: nvidia-settings could not find the registry key file.(…)

but thats about it

I’m running nvidia driver 470.86 and X11
x11

I read online that wayland is especially bad with nvidia gpus so I have also been staying away from it.

I’m currently running the two commands from @get_off_my_lawn and will see if anything shows up. multitail is neat!
Will try to find desktop fps counter as well.

And nope, I didn’t try running without KVM. I really should have tried this first =x will do that if nothing shows up in the logs.

Thanks both of you!

The nVidia errors you have won’t be what I see.
NVRM: Xid (PCI:0000:26:00): 31, pid=477801, Ch 00000018, intr 00000000. MMU Fault: ENGINE GRAPHICS HUBCLIENT_SCC faulted @ 0x20_061e7000. Fault is of type FAULT_PDE ACCESS_TYPE_VIRT_READ

Mine are from the kernel/drivers crapping themselves here and there due several GPU’s with segregated 3D workloads.

Why are you running 470? That’s very old. I don’t touch gnome but I know composition can be disabled in most DE’s. (Did some poking after the fact and yeah looks like Gnome is Gnome i.e. no user control ala Applesque dictation.)

Wayland is a bag of crap for any GPU. Frankly it’s a massive step backwards but “stupid” is trendy these days which is why we have Wayland and PipeWire. Just as a quick note about why Wayland is stupid. At a time when even the most garbage GPU costs “I’m going to space” money Wayland comes along seeking to reduce any GPU outside the first a complete waste of money and resources. It reduces your GPU to a crappy output splitter that does nothing but pass a frame buffer. So if you have four Titans…nope you have ONE Titan with four Titans outputs. $10K in worthless GPU’s that you can’t offload or delegate to (minus maybe pure cuda workloads)…just creating heat, wasting power…dumping 100% of the workload on the primary GPU…yeah BRILLIANT! Fing morons.

Right now sadly not much has been narrowed down so there are tons of things to try yet if the logs don’t show anything at the time you notice the behavior. First things I’d try though is get to the current nVidia drivers, get your kernel as new as you can without building and if it still happens try a lighter DE with a different compositor just to feel things out. I know that’s kinda a crap suggestion because if you like gnome and it fits your workflow moving to something else can be jarring if not just pure suck. I just know Gnome/GTK has a lot of issues…well it has for a long time but with the GTK4 newness I’d imagine there are some growing pains and other issues lurking. I mean the GTK3 transition they broken their own compatibility weekly ffs.

1 Like

I’ve actually seen a lot of super whack and inconsistent behavior from any Ubuntu release newer than 19.04. I’ve never been able to figure out what is the core change that made everything after 18.04 trash but…it’s been trash. Installers can’t finish or reboot, systemd unmounting the freaking root partition or anything mounted in general while said mount is in use, power management bizarities, upgrades that can’t do basic things to succeed, broken package loop hells. Every machine I upgraded from 18.04 either got put right back or moved to Arch/Garuda because things were just completely unusable. Last Ubuntu install I did was server and that new installer is terrible. On par with what I just said it gibbed two installs and ignored the do not touch the filesystem declaration and wiped a drive it shouldn’t have…Canonical seems asleep at the wheel these days.

1 Like

I’m back with good news!

So there were no logs showing when it was slowing down. I ran it for a while to make sure to get multiple slowdown occurrences but still nothing.

So then I tried your other suggestion of running it without KVM, and yup this was it, no slowdowns. I went ahead and plugged it back into the KVM but this time the USB3 port which is just passthrough. And so far I have been running it for around a day and so far no slowdowns (knocks on wood).
So the issue seems to be with the HID ports, I definitely tried like all the HID ports and still had the issue but never tried the USB3 since HID had some extra stuff for hotkeys if I remember right. It also worked fine before so it didn’t really occur to me to think of that as possible issue.
They’re wired differently so I guess thats why USB3 worked?
It’s not perfect since theres now a delay before mouse gets detected again when switching which wasnt there with the hid ubs2 ports but it works so I’m happy!

Huge thanks for pointing it out! And also for the neat apps like ratbag!

Ah, I did not know that about wayland and that sure is a waste of gpus.
Four titans are definitly out of my league but you mentioned 3D workloads so a professional environment? Cant let gpus sit in that case even more so.
I wanted to mess around with LibVF.IO but thats sharing one gpu into multiple parts instead of delegating work to multiple gpus. It sounds neat, especially during the GPU shortage.

I have had pretty good experience with Ubuntu so far, aside nvidia driver update issue and this mouse thingy.
I was running 470 driver since that was newest from the built in software updater when I did a fresh install some time ago. One time I got the “Partial Upgrade” message due to the nvidia drivers and I installed it anyways and then I couldnt connect to the internet for some reason. Turns out I missed some nvidia packages while doing the partial update and that broke stuff. I just booted into grub and selected the previous kernel to boot into and reupdated and that fixed it however sleep mode was broken since then and I needed to make changes to /proc/acpi/wakeup via cron on boot lol
After that my take on it was dont touch nvidia driver if its not broken.
I installed a newer version now though, 510.

I really like 18.04, still using it on my laptop since it just works.
20.04 definitely has more issues but this nvidia update one was like the top one for me since it actually broke stuff. I had an issue installing PopOS which is Ubuntu based but not really installing ubuntu itself. I only use LTS releases, have somewhat old hardware and I clean install every LTS release so maybe that helps avoid issues. Switching DEs would be difficult since I currently have ubuntu/gnome set up how I like it with gnome extensions and tweaks so would need time to get used to others.

But it should be all good now, the mouse issue seems fixed from the looks of it. Thanks again @get_off_my_lawn

3 Likes

Well +1 to working heh

I’ve left Ubuntu / Debian in part because they have forced users into a broken system for multi-GPU/XScreen. That said it’s Gnomes fault, but how Ubuntu/Debian does stuff kinda makes it worse.

Man the repos should be on 510 for the nvidia driver by now. I’m on Garuda now and some days it’s still kinda nuts how stuff I’d wait 3 years to get on Ubuntu I get weekly now. All hail the rolling release!

Yeah man 18.04 was the tits! I still have a few XUbuntu 18.04 machines on the network but they aren’t online since 18.04 is EOL. I know sec updates will be for another year or so but their roles don’t need online anyhow. It was actually the fact 18.04 was EOL last year that I started on a hellish journey to find something not broken. Took a long time since at the time I didn’t know what the hell took things from 18.04 everything worked to 19.10+ NOTHING works!

My GPU’s aren’t anything special really. It’s kinda sad how many I have on a shelf doing nothing but things like my old Radeon 4870 draws power like a mofo and the fans sound like a hair dryer at idle. Oldest card I have running right now is a Radeon R9 270x. I was hoping to add more GPU’s and move to a 5XXX TR5 set up but 5XXX is still MIA and since everything is so hostile to Multi GPU now I’m super hesitant to spend any money for something an update could obliterate. Still kills me I’ve been running multi GPU for over 20 years. Started with ISA/EISA cards…then a few EISA/PCI, then a few PCI and an AGP…you get the picture. It’s been a while. Now it’s broken. It wouldn’t be so bad if GPU’s weren’t garbage. Take a RTX3090 for example, it has the same max resolution lock as an old GTX 1080. Meaning they basically limit how you can use the card via that and the limited outputs. With a card like that I expect TWELVE as a minimum for outputs. Even the Radeon WS6800 only does 6 screens. SIX PIDDLY SCREENS! That’s a $1000 a screen! 32Gigs of RAM, SIX SCREENS?! Did you just assume my use case bro? :wink:

OR…buy a few 1060’s (back in the day) for $250 ea BLAM 15 screens for UNDER a $1000.

But yeah I like many GPU’s for split up work loads…and my 12 screens :wink:

1 Like