Monitor Not Showing Signal

The PC was left for a week unplugged from everything for storage, and is now back in my hands. The VGA port suffered what appears to be minor damage, but may be severe. However, the DVI-D port was left completely unharmed. I used a Lenovo DVI-D monitor that I inherited from work to test out the DVI-D port's functionality, and everything fit in like a charm, but still no signal. The monitor goes to "Power Save" after a few seconds (which is normal it seems for monitors to do) but I don't understand why it would do this as this is the same functioning PC I had before with one less port which is the VGA. I figured that in the past my monitor needed me to use the keyboard and mouse to provide a signal, however, my keyboards and mice do not function properly on the computer. With the exception of the mouse, I am using the same keyboard as before, and still the keyboard does not light up or function as far as I know, because there's no signal on my monitor. Ugh, what a hassle, but I recall a similar problem when I built the computer, which was that I had no monitor signal and nothing seemed to work to get it to have a signal. Sadly I do not recall the solution to this problem so I come to you guys.

Let's go over what I have done to try and solve this in summary (I will update this as we go along):


  • I used a DVI-D monitor rather than a VGA as the VGA port is slightly bent and had no signal either.
  • I tried using my keyboard (same as before) and mouse (new one) to get a signal.
  • I checked all power connections coming from my PSU to everything else.
  • I reset the BIOS by resetting the CMOS battery in place.
  • I took out the RAM and put it back where it was. (as a random check)
  • Tested the keyboard and mouse on this computer, which installed the drivers correctly and worked.


To me this sounds like a USB port problem as the monitors typically require any sort of input into the computer to provide a video signal. I have also switched around a USB cable into different pin slots to see if that might work, and I believe this may be the problem but I have run tests with it in both pins. I don't know how I dealt with this last time. Everything is secure as far as cables go I assure you.

Please take time and help me as I have an upcoming editing project to work on and this computer does not have the programs necessary, nor the speed.

  • ASRock FM2A75M-DGS Motherboard
  • AMD APU A10 5800k Processor

A computer does not need a keyboard or mouse to post and show an image on the screen. It sounds to me like a problem with the mother board. I would say listen for post error beep codes, but the board does no look to have a speaker for it.

After extensive research elsewhere it would be completely logical for the CMOS battery to be the problem. Perhaps I need to let it sit out longer, so I decided to experiment and leave it out all of tonight and tomorrow.

Leave it out for that amount of time, should not be needed, 30 seconds to 1 minute max is suitable enough to get you a result.   It may just be the Power Supply is dead, unless you can see fans spinning and or lights to give an indication of power, for instance, keyboard and mice, do the numlock and capslock keys light up etc

That's the thing. My fans and other components work. Just not the keyboard lights and the function either. The mouse does not work as well. I am out of ideas.

Sounds like the Video card has had it (not sure if you tested this on another machine, too much wall of text lol)  And or motherboard is faulty.

Suppose you could try changing pci slot if there's more than one, or since you have such a fantastic APU you can take out the graphics card and plug the monitor into the motherboard directly. or as Goosetav suggested try GPU in another machine. Make sure all cables are connected inside the case.