Mionix Naos 8200 - DEAD!

Hi guys! 

I bought my Naos 8200 barely a month ago, and today I came home from work, turned on my computer, and guess what?


The buttons all still work, L.E.D.'s turn on, but no sensor tracking... I've updated the firmware, tried multiple machines, but no luck, the Naos 8200 is dead.

Now, normally I wouldn't make a big deal about something like this, however, I have NEVER, and I mean NEVER EVER had a mouse FAIL on me.

I've used gaming mice from a LOT of different manufacturers, and I've NEVER had a problem with any of them. I've used Corsair, Gigabyte, Mad Catz, Razer, Microsoft, and Logitech. 

This may seem as hasty, but I'm NEVER going to buy another Mionix mouse. Sorry. I've babied this thing, not a scratch on it, etc. My Corsair M90 I actually got BORED of after a year so I started to try and KILL it so I had an excuse to get my Naos, I tried smashing it on my desk, repeatedly, nope, ended up denting my aluminum mouse pad though! 

Unless Mionix makes some crazy cool nice mouse and it's on sale, I'll take my chances with a PROVEN manufacturer next time. 

I had this same problem with my thermaltake theron except it broke when changing the dpi in the software they provided so it literally killed its self lol

I'm kinda on the same boat as you. I bought the Func MS-3 once it came out. Fortunately, it held for more than a month, more like 4-5 months, but the sensor did die at that point.

I do expect a mouse to die at some point, but 1 month and 1/2 a year is not good enough. I probably won't buy any more products from Func for a while, at least not any mice. After the MS-3 died, I just went back to my 4 year old ACE Edge 3200.