MBR Error after windows update

My computer was installing updates and it seemed to have gotten stuck installing the final update, so I shut it down hoping that the update would succeed a second time around. Upon turning the computer back on, I got the error message "MBR error 1 Press any key to boot from floppy” and pressing a key would give "MBR error 2".

I tried running startup repair once from the install disc which failed.

Next I tried bootrec

  • /fixmbr - said it succeeded but still would not boot
  • /fixboot - said no elements were found
  • /scanos - said no installations found
  • /rebuildbcd - also said no installations found

bootsect /nt60 - doesn't work because the drive is not being assigned a drive letter
bootsect /nt60 SYS - fails as it cannot detect a system partition

I've tried a few of the MBR tools in Hiren's boot cd

  • MbrFix
  • I think another was just mbr.exe
  • Possibly MBRWizard but I can't really remember

Running bcdedit with no arguments says something along the lines of no boot configurations found.

chkdsk also does not work because the drive is not being assigned a drive letter.

The drive does show up when looking at it in diskpart, but it shows no volumes or partitions on the drive. Disk management shows the whole drive as unallocated space.

I have tried a few partition recovery tools such as TestDisk and EaseUS Partition Recovery, neither of them found any partitions using the quick or deep scans.

Somewhere in between these attempted fixes, attempting to boot from the drive would result in a boot device not found error (even when the correct device was being booted from in the bios) instead of the MBR errors 1 and 2 I was getting before. This is it's current state in case that wasn't clear.

After attempting a few different fixes, I ran three successive startup repairs and each one failed to recreate the partition table with error code 0x490.

After some more attempted fixes startup repair said it was successful in repairing the partition table although I ran it twice and still did not boot.

There are two potential fixes I have thought of, but I have no idea if they would work or how to fully do them.

  1. I have a full disk image of the drive which is quite old and even from a previous windows install. I was wondering if it would be possible to copy the MBR from the image to the drive in hopes that it would be the same or similar enough to where it worked/could be repaired.
  2. I'm pretty sure that the drive is set up with a 100mb system partition that is followed by another partition filling up the rest of it. This is also the same layout that is in the system image I have. I was wondering if there would be a way to recreate the partition table using that information without having to reformat the drive so the data is left intact.

I think that covers most of it. If anyone has any suggestions they would be greatly appreciated.

So yeah, I don't know of any tools that can recover from a situation that dire reliably. Once the MBR is lost, all context of partitions/filesystems has been lost and hence the OS and all related files are just gone.

If it's a physical disk issue, then it may be possible to recover via spinrite, but yours was damaged from the software side. If only slightly damaged you can run bootrec with the options but you've already done that.

bootrec /fixmbr should have fixed that, if that doesn't work, then the system repair disk might be able to mess with things at that level. But if that doesn't work...

Those workarounds you're thinking of are not...supported by either the software you're using or windows or any other software vendor that I know of.

The only way to do what you're thinking is to image a second drive, then to use a hex editor or software to capture the first 512bytes(?) of the disk and restore them to the existing drive.

Actually I think Disk Commander, part of MS's DaRT can maybe do this. It's not designed for this tho.

Prolly not going to work, but wanna try it anyway? o.o

DaRT is very picky about versions(?) and architecture tho (win 7/8/8.1/10 x86 or x64). Which exact windows version was on the disk?

Post that so I can know which version of DaRT to use.

Note: The MBR contains partitioning information. Restoring from a "similar configuration disk" will permenately erase the partitions that were sorta? on the drive. The configuration must be identical, which in your unique case, is possible with the byte-per-byte system image you created. Also: Images are compressed so restoring them is the only way to "uncompress" the MBR into a suitable format for capture.

Edit: So...the disk wasn't encrypted using BitLocker/TC or another FDE software correct?