Return to Level1Techs.com

Manjaro will not boot with undervolted CPU Turns off/on infinite loop

Hey everyone. I am very new to Linux and I am having a complication I don’t know how to solve. For starters I have an Intel 9900KS set to 4.8ghz with a voltage of 1.22v with a Gigabyte Aorus Z390i Motherboard inside a SSUPD Meshlicious case. I moved away from water cooling and wanted to go with Air cooling but in order to keep my temps under control I had to under volt and under clock my CPU. Unfortunately in doing so I can no longer boot into Manjaro. Windows works flawlessly, but every time I try to boot into Manjaro after pressing enter on the boot loader, the entire PC will shut down about a second and half after that and will do so indefinitely until I change the VCore back to AUTO.

Is there something by chance that Manjaro or Linux in general is looking for or doesn’t like about my bios settings? I definitely want to learn Linux but this problem is keeping me from even running the OS.

I figure this, LTT forums and Manjaro forums I hopefully will get this tackled.

What testing have you done in Windows to determine it stable?

Played games, ran cinebench, AIDA64, runs like normal as far as I can tell

1 Like

Linux CPU power management is different from Windows, and it’s known to cause problems with certain platforms. Typically, you hear about it with first or second gen Ryzen, though.
I think it’s very likely that your CPU undervolt isn’t stable when dropping to idle, and Windows is just handling ramping down better.

When using negative voltage offsets, this is a common problem, as you often have much less overhead to reduce idle voltage and remain stable. If you used a fixed voltage, it should solve your problem at the cost of higher idle temps/power draw and a shorter(but still probably very long) CPU use life.
Makes me miss using things like PhenomMSRTweaker for overclocking. Could set each clock state voltage, ramp up/down loads and timing, and absolutely dial in your CPU for maximum performance and power savings. Modern overclocking just isn’t anywhere near as good.

Ed: Looks like there’s actually stuff to do this for Ryzen and Bulldozer generation parts after all. I don’t know if Intel has anything like that, though. Their XTU is decent, doesn’t have individual p-state voltage controls afaik.

Ed2: Fixed voltage means I’m wrong.

1 Like

Another person told me to try and black list acpi_cpufreq I am using a fixed voltage and a mid range LLC. But I don’t know enough to know if it makes a difference or not.

1 Like

So you want to overclock, while under-volting and under-clocking the CPU. All that with an already set fixed / low cpu voltage? For starters raise the cpu voltage to something higher, that cpu can go way higher than 1.22v and doubt it’s good for it’s lifespan running at that speed with that voltage set aswell.

Power management across operating systems can’t be compared. Windows has WAY better power management and tweaks, macs even more so. Linux wins third place, in regards to that unfortunately…

And yeah u don’t want to blacklist acpi_cpufreq, not entirely sure but doubt it would even boot if that setting is blacklisted. Perhaps it was recommended because someone thinks that blacklisting a linux setting will make bios power management override the operating system.

That’s not how linux works, or didn’t last time i checked years ago. Who knows bioses have gone from single digit megabytes to double or even tripple digits, so it may work. Although much more likely on a laptop, than a desktop. As acpi’s are configured differently on laptops.

So on linux it’s somewhat more of the opposite, where you’re more likely to blacklist your bios than the other way around. At least on a acpi level, pun intended…

There are countless of scripts and guides on gitlab / github that mess with both graphic, cpu and general power management. U could check some of those out, would be more useful and a learning process compared to asking or hoping for one or two miracle terminal commands that just makes everything work. Good luck :+1:

As others have said, there is no special answer for your problem. Sounds like your setup is close to the edge of stability. I suggest you raise the CPU voltage and/or lower the clock frequency until Linux boots & seems stable. Run some “stress testing” software & adjust until “stable enough”. Then fine-tune until you are satisfied, or worn out.

I have a fear the worn out part will be inevitable but I welcome it. This is the fun stuff.

I don’t want to overclock at all. I need to underclock and undervolt to maintain a decent temp with my setup. I ditched my 280mm AIO in favor of a Noctua NH-L12s and stock my cpu will obviously thermal throttle the TDP is way more than the Noctua can handle but within Windows at least with my CPU set to 4.8ghz and 1.22v it runs perfectly for what I use it for.

1 Like

@Fuss Ummm, I think the 9900k stock frequency ranges from 3.6 GHz base to a maximum of 4.7 GHz for all cores, right? Then higher for fewer cores, up to 5.0 GHz for a single core?

So it sounds like you may have set up an undervolt & overclock, as @0comment suggested.

Have you tried lowering the target PL1 and PL2 TDP settings to, say, 65 and 75w respectively?
I think they’re something like 95 and 250w for that CPU, and especially if your board is just going to turbo it all the way all the time, this can help your CPU keep it’s self in check.

I have the KS so it’s all core 5ghz all the time.

I’m going to be honest I don’t know what that is or how to do it. But I did find out that it was a voltage/LLC issue. I raised the voltage and it didn’t really help but then remembered I tinkered with the LLC and now that it’s back to normal I can boot again.

I don’t know where it is in bios for 9900KS, but there should be a setting somewhere to control your TDP/power targets. In theory, it should be an easy way to control your heat output.
You would need to disable any “multicore enhancement” or stuff like that, though, as all that does is set the power target to something impossible to hit.